ETSI GR mWT 025 V1.1.1 (2021-03)
Wireless Backhaul Network and Services Automation: SDN SBI YANG models
Wireless Backhaul Network and Services Automation: SDN SBI YANG models
DGR/mWT-0025
General Information
Standards Content (Sample)
GROUP REPORT
Wireless Backhaul Network and Services Automation:
SDN SBI YANG models
Disclaimer
The present document has been produced and approved by the millimetre Wave Transmission (mWT) ETSI Industry
Specification Group (ISG) and represents the views of those members who participated in this ISG.
It does not necessarily represent the views of the entire ETSI membership.
2 ETSI GR mWT 025 V1.1.1 (2021-03)
Reference
DGR/mWT-0025
Keywords
5G, automation, backhaul, data models,
fronthaul, microwave, midhaul, millimetre wave,
mWT, SBI, SDN, Southbound Interface,
transmission, use case, X-Haul, YANG
ETSI
650 Route des Lucioles
F-06921 Sophia Antipolis Cedex - FRANCE
Tel.: +33 4 92 94 42 00 Fax: +33 4 93 65 47 16
Siret N° 348 623 562 00017 - NAF 742 C
Association à but non lucratif enregistrée à la
Sous-Préfecture de Grasse (06) N° 7803/88
Important notice
The present document can be downloaded from:
http://www.etsi.org/standards-search
The present document may be made available in electronic versions and/or in print. The content of any electronic and/or
print versions of the present document shall not be modified without the prior written authorization of ETSI. In case of any
existing or perceived difference in contents between such versions and/or in print, the prevailing version of an ETSI
deliverable is the one made publicly available in PDF format at www.etsi.org/deliver.
Users of the present document should be aware that the document may be subject to revision or change of status.
Information on the current status of this and other ETSI documents is available at
https://portal.etsi.org/TB/ETSIDeliverableStatus.aspx
If you find errors in the present document, please send your comment to one of the following services:
https://portal.etsi.org/People/CommiteeSupportStaff.aspx
Copyright Notification
No part may be reproduced or utilized in any form or by any means, electronic or mechanical, including photocopying
and microfilm except as authorized by written permission of ETSI.
The content of the PDF version shall not be modified without the written authorization of ETSI.
The copyright and the foregoing restriction extend to reproduction in all media.
© ETSI 2021.
All rights reserved.
DECT™, PLUGTESTS™, UMTS™ and the ETSI logo are trademarks of ETSI registered for the benefit of its Members.
3GPP™ and LTE™ are trademarks of ETSI registered for the benefit of its Members and
of the 3GPP Organizational Partners.
oneM2M™ logo is a trademark of ETSI registered for the benefit of its Members and
of the oneM2M Partners. ®
GSM and the GSM logo are trademarks registered and owned by the GSM Association.
ETSI
3 ETSI GR mWT 025 V1.1.1 (2021-03)
Contents
Intellectual Property Rights . 4
Foreword . 4
Modal verbs terminology . 4
Introduction . 4
1 Scope . 6
2 References . 6
2.1 Normative references . 6
2.2 Informative references . 6
3 Definition of terms, symbols and abbreviations . 7
3.1 Terms . 7
3.2 Symbols . 7
3.3 Abbreviations . 7
4 Centralized Wireless Backhaul/X-Haul Automation Controller Value . 8
4.1 Benefits . 8
4.2 Key Success Factors . 9
4.3 Architecture . 9
5 Automation Use Cases Analysis . 10
5.1 Network and Service Auto-discovery. 10
5.1.1 Motivation. 10
5.1.2 Expected value . 10
5.1.3 Functionality description . 11
5.1.4 Gap analysis in standard models . 11
5.2 Services Provisioning . 13
5.2.1 Motivation. 13
5.2.2 Expected value . 13
5.2.3 Functionality description . 13
5.2.4 Gap analysis in standard models . 14
5.3 Performance Analysis & Prediction . 14
5.3.1 Motivation. 14
5.3.2 Expected Value . 15
5.3.3 Functionality description . 15
5.3.4 Gap analysis in standard models . 15
5.4 Smart Alarm Analysis and Fault Prediction . 17
5.4.1 Motivation. 17
5.4.2 Expected value . 17
5.4.3 Functionality description . 17
5.4.4 Gap analysis in standard models . 17
5.5 Power Consumption Optimization . 19
5.5.1 Motivation. 19
5.5.2 Expected value . 19
5.5.3 Functionality description . 19
5.5.4 Gap analysis in standard models . 19
5.6 Interference Handling and Automated Frequency Allocation . 20
5.6.1 Motivation. 20
5.6.2 Expected value . 21
5.6.3 Functionality description . 21
5.6.4 Gap analysis in standard models . 22
6 YANG Models Evolution . 22
7 Conclusions . 23
History . 24
ETSI
4 ETSI GR mWT 025 V1.1.1 (2021-03)
Intellectual Property Rights
Essential patents
IPRs essential or potentially essential to normative deliverables may have been declared to ETSI. The information
pertaining to these essential IPRs, if any, is publicly available for ETSI members and non-members, and can be found
in ETSI SR 000 314: "Intellectual Property Rights (IPRs); Essential, or potentially Essential, IPRs notified to ETSI in
respect of ETSI standards", which is available from the ETSI Secretariat. Latest updates are available on the ETSI Web
server (https://ipr.etsi.org/).
Pursuant to the ETSI IPR Policy, no investigation, including IPR searches, has been carried out by ETSI. No guarantee
can be given as to the existence of other IPRs not referenced in ETSI SR 000 314 (or the updates on the ETSI Web
server) which are, or may be, or may become, essential to the present document.
Trademarks
The present document may include trademarks and/or tradenames which are asserted and/or registered by their owners.
ETSI claims no ownership of these except for any which are indicated as being the property of ETSI, and conveys no
right to use or reproduce any trademark and/or tradename. Mention of those trademarks in the present document does
not constitute an endorsement by ETSI of products, services or organizations associated with those trademarks.
Foreword
This Group Report (GR) has been produced by ETSI Industry Specification Group (ISG) millimetre Wave
Transmission (mWT).
Modal verbs terminology
In the present document "should", "should not", "may", "need not", "will", "will not", "can" and "cannot" are to be
interpreted as described in clause 3.2 of the ETSI Drafting Rules (Verbal forms for the expression of provisions).
"must" and "must not" are NOT allowed in ETSI deliverables except when used in direct citation.
Introduction
Software-Defined Networking (SDN) is an emerging architecture that is dynamic, manageable and cost-effective,
making it ideal for the high-bandwidth, dynamic nature of today's applications. Initially, this architecture aimed to
decouple the control plane from the data plane allowing the network control to become directly programmable and the
underlying infrastructure to be abstracted for applications and network services. The network devices are in that case
limited to the data forwarding. On top of the network devices, an intelligent entity, called "controller" sees the network
as a whole and directly injects the data processing rules on each device.
This concept did not get wide scale adoption into operator's networks. Therefore, the market quickly evolved and
adopted SDN as the set of solutions removing the existing boundaries between the application and network worlds
while conserving the integrity of the equipment data and control planes. As a matter of fact, the network is sometimes
seen as a brake. Each modification still often requires manual intervention without orchestration in most organizations.
Setting up a simple VLAN can sometimes take several days, with the need to configure many devices one by one:
switches, routers, firewalls, etc. Thus, the target became naturally on real network issues: allowing applications to
program the network in order to accelerate and improve its deployment and operation.
The wireless backhaul network, as with other network segments, is inherently effected by this transformation. As a
matter of fact, having open and standardized MW equipment interfaces was identified as the prerequisite for operating a
flexible network across different vendors' equipment and multiple technologies. Most MW vendors are currently
developing NETCONF/YANG features enabling equipment openness. However, there is with no consensus today on
the used data models. Two main MW SDN standards are working on different implementation approaches leading to
the lack of a single clear path forward.
ETSI
5 ETSI GR mWT 025 V1.1.1 (2021-03)
The goal of this work is to accelerate the standardization and implementation of necessary (physical and logical)
interfaces as well as YANG data models by adopting a use cases-driven automation architecture for the wireless
backhaul/X-Haul networks. By this, service providers can select the standards that fit best into their network
architecture, while system vendors can develop solutions to address real customer needs.
To this end, a list of relevant attributes to be considered for each use case is proposed. Moreover, an analysis of existing
standard YANG models (e.g. ONF, IETF, IEEE) is carried out providing gaps identification with respect to the defined
use cases.
ETSI
6 ETSI GR mWT 025 V1.1.1 (2021-03)
1 Scope
The present document provides information about the standardized YANG data models as they have been developed
within IETF, IEEE and ONF to be used in a use cases-driven automation architecture for the wireless backhaul/X-Haul
networks. Moreover, it provides gap analysis of existing standard YANG models (e.g. ONF, IETF, IEEE) and it
discusses potential implementation issues.
2 References
2.1 Normative references
Normative references are not applicable in the present document.
2.2 Informative references
References are either specific (identified by date of publication and/or edition number or version number) or
non-specific. For specific references, only the cited version applies. For non-specific references, the latest version of the
referenced document (including any amendments) applies.
NOTE: While any hyperlinks included in this clause were valid at the time of publication, ETSI cannot guarantee
their long term validity.
The following referenced documents are not necessary for the application of the present document but they assist the
user with regard to a particular subject area.
[i.1] ETSI GR mWT 016: "Applications and use cases of Software Defined Networking (SDN) as
related to microwave and millimetre wave transmission".
[i.2] IETF RFC 6020 (October 2010): "YANG - A Data Modeling Language for the Network
Configuration Protocol (NETCONF)".
[i.3] IETF RFC 7950 (August 2016): "The YANG 1.1 Data Modeling Language".
TM
[i.4] IEEE 802.3.2 : "IEEE Standard for Ethernet - YANG Data Model Definitions".
TM
[i.5] IEEE 802.1 : "IEEE Standard for Local and Metropolitan Area Networks".
TM
[i.6] IEEE 802.1Qcp : "IEEE Standard for Local and metropolitan area networks -- Bridges and
Bridged Networks -- Amendment 30: YANG Data Model".
[i.7] IETF RFC 8343: "A YANG Data Model for Interface Management".
[i.8] IETF RFC 8348: "A YANG Data Model for Hardware Management".
[i.9] IETF RFC 8561: "A YANG Data Model for Microwave Radio Link ".
[i.10] IETF RFC 8575: "YANG Data Model for the Precision Time Protocol (PTP)".
[i.11] IETF RFC 8632: "A YANG Data Model for Alarm Management".
[i.12] draft-liu-dhc-dhcp-yang-model: "Yang Data Model for DHCP Protocol".
[i.13] draft-ietf-netmod-intf-ext-yang: "Common Interface Extension YANG Data Models".
[i.14] ONF TR-512 v1.4: "Core Information Model (CoreModel)".
NOTE: Available at https://opennetworking.org/wp-content/uploads/2018/12/TR-512_v1.4_OnfCoreIm-info.zip.
[i.15] ONF TR-532 v2.0: "Microwave Information Model".
[i.16] ONF TR-532 v1.1: "Microwave Information Model".
ETSI
7 ETSI GR mWT 025 V1.1.1 (2021-03)
3 Definition of terms, symbols and abbreviations
3.1 Terms
Void.
3.2 Symbols
Void.
3.3 Abbreviations
For the purposes of the present document, the following abbreviations apply:
AR Availability Ratio
BBE Background Block Error
BCA Bands and Carrier Aggregation
BER Bit Error Ratio
BSS Business Support System
CBS Committed Burst Size
CIR Committed Information Rate
CM Current Modulation
C-VLAN Customer - Virtual Local Area Network
DHCP Dynamic Host Configuration Protocol
DM Data Model
EB Errored Block
EBS Excess Burst Size
EIR Excess Information Rate
EMS Element Management System
ES Errored Second
FER Frame Error Ratio
FLR Frame Loss Ratio
HW Hardware
IEEE Institute of Electrical and Electronics Engineers
IETF Internet Engineering Task Force
IM Information Model
IP Internet Protocol
LLDP Link Layer Discovery Protocol
LOS Line Of Sight
MAC Media Access Control
MSE Mean Square Error
MTBF Mean Time Between Failures
MTU Maximum Transmission Unit
MW MicroWave
N.A Not Available
NE Network Element
NMS Network Management System
OI Outage Intensity
ONF Open Networking Foundation
OPEX Operational Expenditure
OSS Operations Support System
PCP Priority Code Point
PEA Percent Ethernet service Availability
PEU Percent Ethernet service Unavailability
QoS Quality of Service
RF Radio Frequency
RFC Request For Comment
RSL Received Signal Level
ETSI
8 ETSI GR mWT 025 V1.1.1 (2021-03)
SBI SouthBound Interface
SDN Software Defined Networking
SES Severely Errored Second
SNR Signal to Noise Ratio
S-VLAN Service - Virtual Local Area Network
TTL Time To Live
UML Unified Modeling Language
UR Unavailability Ratio
VLAN Virtual Local Area Network
XPIC Cross-Polarization Interference Cancelling
YANG Yet Another Next Generation
4 Centralized Wireless Backhaul/X-Haul Automation
Controller Value
4.1 Benefits
One of the main challenges that service providers face today is to improve end-users' satisfaction - e.g. delivering or
upgrading to a new service, whilst having to control multiple isolated-managed and often complicated network systems.
This urgently results to the need to increase operational efficiency and enable network agility and programmability. The
introduction of the concept of smart network and services automation can be a catalyst towards such business and
operational objectives and figure 1 illustrates the foreseen benefits when deploying a centralized wireless backhaul/X-
Haul domain controller to address automation.
Figure 1: Smart Network and Services Automation Benefits
ETSI
9 ETSI GR mWT 025 V1.1.1 (2021-03)
4.2 Key Success Factors
In order to benefit from automation, open and standardized network interfaces and data models should be used. In
addition, the required set of data models have to be technically effective and mature, allowing ease of implementation
and future upgrades whilst also taking care of backwards compatibility. Last, but not least, any use case driven
automation initiative needs industry-wide collaboration, among service providers and technology makers, to achieve
commonly accepted standardized and open interfaces at scale. Figure 2 captures the aforementioned key factors for
successful deployments when establishing a network automation framework, which of course applies in the context of
centralized wireless backhaul/X-Haul domain controller, as well.
Figure 2: Key Success Factors for Smart Network & Services Automation
4.3 Architecture
The architecture considered in this work is depicted in figure 3. The focus is on the YANG data models to be
implemented on the Network Element (NE) level to enable automated operations across multi-vendor MW domain
through the SouthBound Interface (SBI) (red interface in figure 3). Any other interfaces that can exist in a real network
topology (e.g. with the hierarchical controller, other transport domain controllers, etc.) are out of the scope of the
present document and they are only shown to indicate that the wireless backhaul/X-haul domain controller can be part
of a wider SDN architecture for transport and end-to-end network and services automation framework.
ETSI
10 ETSI GR mWT 025 V1.1.1 (2021-03)
Figure 3: Centralized Wireless Backhaul/X-Haul Domain Controller Architecture
5 Automation Use Cases Analysis
5.1 Network and Service Auto-discovery
5.1.1 Motivation
The use case area of network and service discovery can be broken down into two logical applications.
Auto-Discovery - Traditional microwave NE deployment procedures can often be more complex than other transport
technology domains due to the detailed planning, coordination, spectrum license applications and configuration of
physical layer radio attributes before commissioning can take place. In addition, the initial installation procedure
typically requires significant time and effort from expert resource before higher layer protocols can be established for
further configuration and service provisioning. A standardized and interoperable SBI has the potential for near real-time
integration of multi-vendor NE with centralized network planning tools to automate or assist commissioning,
optimization and validation of new radio links.
NE Capabilities and Domain Characteristics - The ability to track and query configuration capabilities and active
topology of the network underpin the management ability of the operator. An SDN ambition for the operator is the
ability to provision end to end services regardless of the underlying transport technology. This can only be realized with
effective technology domain abstraction where technology specific automation (based on NE capabilities and topology)
can be handled by domain controllers. A standardized super-set of technology specific capabilities (e.g. physical links,
ports, HW profile and services) would allow network services to be implemented in multi-vendor, multi-technology
domain.
5.1.2 Expected value
The most significant benefit for operators of automatic discovery of NE (which in turn facilitates automated or semi-
automated commissioning and inventory systems) is through OPEX cost savings. Deployment of microwave
transmission equipment is a particularly costly and time consuming procedure where standardized interfaces and data
models can enable faster time to market and enable greater flexibility of suppliers and supplier equipment without the
(often cost prohibitive) proprietary NMS/OSS/BSS integration.
ETSI
11 ETSI GR mWT 025 V1.1.1 (2021-03)
Auto-discovery of network equipment topology and capabilities also could enable seamless integration of new
applications for near real-time visualization of microwave link information relevant to planning and operational teams.
New applications could permit accurate and frequent asset and inventory management tasks, track upgrades and their
impacts, re-configuration and security patching across all domains. Where such procedures are currently manual or part-
manual processes there is significant scope for error and inaccuracy which could be removed through automated
configuration audits and automatic correction against the target/desired configuration.
5.1.3 Functionality description
Network and Services auto-discovery is a function that will allow to automatically detect and connect new microwave
nodes to a management system and to retrieve inventory information from the node.
5.1.4 Gap analysis in standard models
Table 1: UC1 Gap Analysis
ONF IETF/IEEE
Attribute
Parameter
Parameter Name Model/Submodel Model/Submodel
Name
Per Hardware Instance (i)
model-name/ ietf-hardware (IETF
Model Number model-identifier ONF TR-512 v1.4 [i.14]
physical-index RFC 8348 [i.8])
ietf-hardware (IETF
Model Version version ONF TR-512 v1.4 [i.14] model-name
RFC 8348 [i.8])
ietf-hardware (IETF
Serial Number serial-number ONF TR-512 v1.4 [i.14] serial-num
RFC 8348 [i.8])
ietf-hardware (IETF
Hardware Version part-type-identifier ONF TR-512 v1.4 [i.14] hardware-rev
RFC 8348 [i.8])
firmware-rev/ ietf-hardware (IETF
Modem Version n.a (under development) -
software-rev RFC 8348 [i.8])
control-construct/name or ietf-hardware (IETF
NE Name ONF TR-512 v1.4 [i.14] name
control-construct/label RFC 8348 [i.8])
control-construct/name or ietf-hardware (IETF
NE Description ONF TR-512 v1.4 [i.14] description
control-construct/label RFC 8348 [i.8])
ietf-hardware (IETF
Firmware Version n.a (under development) - firmware-rev
RFC 8348 [i.8])
ietf-hardware (IETF
Software Version n.a (under development) - software-rev
RFC 8348 [i.8])
Data Model n.a but communicated Revision ietf-hardware (IETF
-
Version during netconf session statement RFC 8348 [i.8])
Uuid(IETF
RFC 8348 ietf-hardware (IETF
[i.8])/ RFC 8348 [i.8])/
control-construct/logical- if-index(IETF ietf-interfaces(IETF
Interface Id termination-point/layer- ONF TR-512 v1.4 [i.14] RFC 8343 RFC 8343 [i.7])/
protocol/local-id [i.7])/ ietf-microwave-
id(IETF radio-link (IETF
RFC 8561 [i.9 RFC 8561 [i.9])
])
control-construct/top-level-
ietf-hardware (IETF
Chassis id equipment/uuid (core- ONF TR-512 v1.4 [i.14] physical-index
RFC 8348 [i.8])
model)
Per Radio Interface (i)
ietf-microwave-
transmitter-is-on ONF TR-532 v2.0 [i.15]/air-
RF Enabled tx-enabled radio-link (IETF
receiver-is-on interface-configuration
RFC 8561 [i.9])
channel-
ietf-microwave-
Channel ONF TR-532 v2.0 [i.15]/air- separation/
duplex-distance-list radio-link (IETF
Spacing/Duplex interface-capability duplex-
RFC 8561 [i.9])
distance
ETSI
12 ETSI GR mWT 025 V1.1.1 (2021-03)
ONF IETF/IEEE
Attribute Parameter
Parameter Name Model/Submodel Model/Submodel
Name
selected-cm
*In case of
ietf-microwave-
Reference min modulation proposed adaptive
- radio-link (IETF
Modulation instead mode, this
RFC 8561 [i.9])
attribute is not
defined.
ietf-microwave-
Adaptive ONF TR-532 v2.0 [i.15]/air-
adaptive-modulation-is-on adaptive radio-link (IETF
Modulation interface-configuration
RFC 8561 [i.9])
Maximum Physical ietf-microwave-
ONF TR-532 v2.0 [i.15]/air- available-
Modulation modulation-scheme radio-link (IETF
interface-capability max-acm
(see note 1) RFC 8561 [i.9])
Current Physical ietf-microwave-
ONF TR-532 v2.0 [i.15]/air-
Modulation modulation-scheme actual-tx-cm radio-link (IETF
interface-capability
(see note 2) RFC 8561 [i.9])
ietf-microwave-
ONF TR-532 v2.0 [i.15]/air-
Tx Frequency tx-frequency tx-frequency radio-link (IETF
interface-configuration
RFC 8561 [i.9])
ietf-microwave-
ONF TR-532 v2.0 [i.15]/air-
Rx Frequency rx-frequency rx-frequency radio-link (IETF
interface-configuration
RFC 8561 [i.9])
ietf-microwave-
Channel ONF TR-532 v2.0 [i.15]/air- channel-
channel-bandwidth radio-link (IETF
Bandwidth interface-capability separation
RFC 8561 [i.9])
actual- ietf-microwave-
ONF TR-532 v2.0 [i.15]/air-
Tx Power tx-power transmitted- radio-link (IETF
interface-configuration
level RFC 8561 [i.9])
ietf-microwave-
ONF TR-532 v2.0 [i.15]/air-
Adaptive Tx Power tx-level-cur atpc radio-link (IETF
interface-status
RFC 8561 [i.9])
ietf-microwave-
Adaptive Tx Power ONF TR-532 v2.0 [i.15]/air- atpc-lower-
atpc-tx-power-min radio-link (IETF
Minimum interface-configuration threshold
RFC 8561 [i.9])
ietf-microwave-
Adaptive Tx Power ONF TR-532 v2.0 [i.15]/air- atpc-upper-
tx-power radio-link (IETF
Maximum interface-configuration threshold
RFC 8561 [i.9])
ietf-microwave-
ONF TR-532 v2.0 [i.15]/air-
Polarization polarization polarization radio-link (IETF
interface-configuration
RFC 8561 [i.9])
ietf-microwave-
ONF TR-532 v2.0 [i.15]/air-
XPIC xpic-is-on xpic-pairs radio-link (IETF
interface-configuration
RFC 8561 [i.9])
BCA n.a. - n.a. -
Per Ethernet/Port (i)
ONF TR-532 v2.0
ietf-interfaces(IETF
Port Enabled interface-is-on [i.15]/wire-interface- enabled
RFC 8343 [i.7])
configuration
ONF TR-532 v2.0 ietf-interfaces(IETF
Port ID local-id if-index
[i.15]/core-model RFC 8343 [i.7])
ONF TR-532 v2.0
ietf-interfaces(IETF
Port Name wire-interface-name [i.15]/wire-interface- name
RFC 8343 [i.7])
configuration
ONF TR-532 v2.0
Physical Layer ietf-interfaces(IETF
fixed-pmd-kind [i.15]/wire-interface- speed
Speed RFC 8343 [i.7])
configuration
ONF TR-532 v2.0
ietf-interfaces(IETF
Duplex Mode fixed-pmd-kind [i.15]/wire-interface- type
RFC 8343 [i.7])
configuration
ietf-interfaces(IETF
ONF TR-532 v2.0 RFC 8343 [i.7])/
phys-address/
MAC Address configured-mac-address [i.15]/mac-interface- ietf-if-ethernet-
mac-address
configuration like(draft-ietf-netmod-
intf-ext-yang [i.13])
ETSI
13 ETSI GR mWT 025 V1.1.1 (2021-03)
ONF IETF/IEEE
Attribute Parameter
Parameter Name Model/Submodel Model/Submodel
Name
ONF TR-532 v2.0 ieee802-ethernet-
auto-pmd-negotiation-is-
Flow Control [i.15]/wire-interface- flow-control interface(IEEE 802.3.2
on
configuration [i.4])
ietf-ptp(IETF
Sync Ethernet n.a - ietf-ptp
RFC 8575 [i.10])
ieee802-d
...








Questions, Comments and Discussion
Ask us and Technical Secretary will try to provide an answer. You can facilitate discussion about the standard in here.
Loading comments...