ETSI GS NFV-SOL 023 V5.3.1 (2025-09)
Network Functions Virtualisation (NFV) Release 5; Protocols and Data Models; Specification of protocol and data model solutions for CMF - NFV-MANO reference point
Network Functions Virtualisation (NFV) Release 5; Protocols and Data Models; Specification of protocol and data model solutions for CMF - NFV-MANO reference point
DGS/NFV-SOL023
General Information
Standards Content (Sample)
GROUP SPECIFICATION
Network Functions Virtualisation (NFV) Release 5;
Protocols and Data Models;
Specification of protocol and data model solutions for
CMF - NFV-MANO reference point
Disclaimer
The present document has been produced and approved by the Network Functions Virtualisation (NFV) ETSI Industry
Specification Group (ISG) and represents the views of those members who participated in this ISG.
It does not necessarily represent the views of the entire ETSI membership.
2 ETSI GS NFV-SOL 023 V5.3.1 (2025-09)
Reference
DGS/NFV-SOL023
Keywords
data models, MANO, NFV, protocol
ETSI
650 Route des Lucioles
F-06921 Sophia Antipolis Cedex - FRANCE
Tel.: +33 4 92 94 42 00 Fax: +33 4 93 65 47 16
Siret N° 348 623 562 00017 - APE 7112B
Association à but non lucratif enregistrée à la
Sous-Préfecture de Grasse (06) N° w061004871
Important notice
The present document can be downloaded from the
ETSI Search & Browse Standards application.
The present document may be made available in electronic versions and/or in print. The content of any electronic and/or
print versions of the present document shall not be modified without the prior written authorization of ETSI. In case of any
existing or perceived difference in contents between such versions and/or in print, the prevailing version of an ETSI
deliverable is the one made publicly available in PDF format on ETSI deliver repository.
Users should be aware that the present document may be revised or have its status changed,
this information is available in the Milestones listing.
If you find errors in the present document, please send your comments to
the relevant service listed under Committee Support Staff.
If you find a security vulnerability in the present document, please report it through our
Coordinated Vulnerability Disclosure (CVD) program.
Notice of disclaimer & limitation of liability
The information provided in the present deliverable is directed solely to professionals who have the appropriate degree of
experience to understand and interpret its content in accordance with generally accepted engineering or
other professional standard and applicable regulations.
No recommendation as to products and services or vendors is made or should be implied.
No representation or warranty is made that this deliverable is technically accurate or sufficient or conforms to any law
and/or governmental rule and/or regulation and further, no representation or warranty is made of merchantability or fitness
for any particular purpose or against infringement of intellectual property rights.
In no event shall ETSI be held liable for loss of profits or any other incidental or consequential damages.
Any software contained in this deliverable is provided "AS IS" with no warranties, express or implied, including but not
limited to, the warranties of merchantability, fitness for a particular purpose and non-infringement of intellectual property
rights and ETSI shall not be held liable in any event for any damages whatsoever (including, without limitation, damages
for loss of profits, business interruption, loss of information, or any other pecuniary loss) arising out of or related to the use
of or inability to use the software.
Copyright Notification
No part may be reproduced or utilized in any form or by any means, electronic or mechanical, including photocopying and
microfilm except as authorized by written permission of ETSI.
The content of the PDF version shall not be modified without the written authorization of ETSI.
The copyright and the foregoing restriction extend to reproduction in all media.
© ETSI 2025.
All rights reserved.
ETSI
3 ETSI GS NFV-SOL 023 V5.3.1 (2025-09)
Contents
Intellectual Property Rights . 7
Foreword . 7
Modal verbs terminology . 7
1 Scope . 8
2 References . 8
2.1 Normative references . 8
2.2 Informative references . 9
3 Definition of terms, symbols and abbreviations . 9
3.1 Terms . 9
3.2 Symbols . 9
3.3 Abbreviations . 9
4 Overview of Certificate Management . 10
4.1 Introduction . 10
4.2 Overview of protocols and data models . 10
4.2.1 Summary of CMPv2 . 10
4.2.1.1 Introduction . 10
4.2.1.2 Feature summary . 10
4.2.1.3 Involved entities . 11
5 Certificate Management interface . 11
5.1 Description . 11
5.2 NFV operation mapping to profiled solution . 12
5.2.1 Certificate Signing Request . 12
5.2.2 Revoke operation . 12
5.3 Sequence diagrams . 12
5.3.1 Flow of the Registration of the Subject . 12
5.3.2 Flow of the Deregistration of the Subject . 13
5.3.3 Flow of the CSR Request . 14
5.3.4 Flow of the Revocation of the certificate . 15
5.3.5 Flow of the Query of the subject . 15
5.3.6 Flow of the Query of the certificate . 16
5.4 URI structure and methods . 17
5.5 Input/Output parameter mapping between NFV data model and profiled solution data models . 18
5.5.1 Introduction. 18
5.5.2 Input parameters to Certificate Management interfaces . 19
5.5.2.1 Introduction . 19
5.5.2.2 CMPv2 PKIMessage structure . 19
5.5.2.3 CMPv2 PKIHeader structure . 19
5.5.2.4 CMPv2 PKIBody structure . 20
5.5.2.5 CMPv2 Certification Request structure . 21
5.5.2.6 CMPv2 Revocation Request structure . 22
5.5.3 Output parameters to Certificate Management interfaces . 22
5.5.3.1 Introduction . 22
5.5.3.2 CMPv2 CertRepMessage structure . 22
5.5.3.3 CMPv2 Revocation Response structure . 23
5.6 Additional features . 24
5.6.1 Description . 24
5.6.2 Version . 24
5.6.3 Resources . 24
5.6.3.1 Introduction . 24
5.6.3.1.1 Overview . 24
5.6.3.1.2 Task resources that trigger Certificate Management operations . 24
5.6.3.2 Resource: API versions . 24
5.6.3.3 Resource: Subject . 24
5.6.3.3.1 Description . 24
ETSI
4 ETSI GS NFV-SOL 023 V5.3.1 (2025-09)
5.6.3.3.2 Resource definition . 24
5.6.3.3.3 Resource methods . 25
5.6.3.4 Resource: Individual Subject . 27
5.6.3.4.1 Description . 27
5.6.3.4.2 Resource definition . 27
5.6.3.4.3 Resource methods . 27
5.6.4 Data model . 29
5.6.4.1 Introduction . 29
5.6.4.2 Resource and notification data types . 29
5.6.4.2.1 Introduction . 29
5.6.4.2.2 Type: SubjectInstance . 29
5.6.4.2.3 Type: RegistrationRequest . 30
5.6.4.3 Referenced structured data types . 30
5.6.4.3.1 Introduction . 30
5.6.4.3.2 Type: CertSubjectData . 31
5.6.4.4 Referenced simple data types and enumerations . 31
5.6.4.4.1 Introduction . 31
5.6.4.4.2 Simple data types . 31
5.6.4.4.3 Enumerations . 31
5.7 OID consideration . 31
5.7.1 Introduction. 31
5.7.2 Conventions for info type attribute . 31
5.7.3 Certificate type . 32
5.7.3.1 Introduction . 32
5.7.3.2 VNFCI Certificate . 32
5.7.3.3 VNF OAM Certificate. 32
5.7.4 Type of certificate handling . 32
5.7.4.1 Introduction . 32
5.7.4.2 Direct mode . 32
5.7.4.3 Delegation mode . 32
7 Certificate Notification interface . 33
7.1 Description . 33
7.2 Version . 33
7.3 Sequence diagrams . 34
7.3.1 Flow of managing subscriptions . 34
7.3.2 Flow of sending notifications. 35
7.4 Resource structure and methods . 36
7.5 Resources . 37
7.5.1 Introduction. 37
7.5.2 Resource: API versions . 37
7.5.3 Resource: Subscriptions . 37
7.5.3.1 Description . 37
7.5.3.2 Resource definition . 37
7.5.3.3 Resource methods . 37
7.5.3.3.1 POST . 37
7.5.3.3.2 GET . 38
7.5.3.3.3 PUT . 39
7.5.3.3.4 PATCH . 40
7.5.3.3.5 DELETE . 40
7.5.4 Resource: Individual subscription . 40
7.5.4.1 Description . 40
7.5.4.2 Resource definition . 40
7.5.4.3 Resource methods . 40
7.5.4.3.1 POST . 40
7.5.4.3.2 GET . 40
7.5.4.3.3 PUT . 41
7.5.4.3.4 PATCH . 41
7.5.4.3.5 DELETE . 41
7.5.5 Resource: Notification endpoint . 42
7.5.5.1 Description . 42
7.5.5.2 Resource definition . 42
ETSI
5 ETSI GS NFV-SOL 023 V5.3.1 (2025-09)
7.5.5.3 Resource methods . 42
7.5.5.3.1 POST . 42
7.5.5.3.2 GET . 42
7.5.4.3.3 PUT . 43
7.5.4.3.4 PATCH . 43
7.5.4.3.5 DELETE . 43
7.6 Data model . 43
7.6.1 Introduction. 43
7.6.2 Resource and notification data types . 43
7.6.2.1 Introduction . 43
7.6.2.2 Type: CertificateSubscriptionRequest . 43
7.6.2.3 Type: CertificateSubscription . 44
7.6.2.4 Type: CertificateLifecycleStateChangeNotification . 44
7.6.3 Referenced structured data types . 45
7.6.3.1 Introduction . 45
7.6.3.2 Type: CertificateChangeNotificationsFilter . 45
7.6.3.3 Type: AffectedSubject . 46
7.6.3.4 Type: AffectedCertificate . 46
7.6.4 Referenced simple data types and enumerations . 47
7.6.4.1 Introduction . 47
7.6.4.2 Simple data types . 47
7.6.4.3 Enumeration: CertificateNotificationVerbosityType . 47
Annex A (informative): Analysis on the existing solutions based on the Certificate
Management interface requirements . 48
A.1 CMP . 48
A.1.1 Overview . 48
A.2 CMPv2 . 48
A.2.1 Overview . 48
A.2.2 Comparison of interface requirements of CMF and CMPv2 . 49
A.2.3 Comparison of Register operation and End Entity Initialization operation . 51
A.2.4 Comparison of Certificate Signing Request operation and initial certification operation . 51
A.2.5 Comparison of Revoke operation and Revocation operation . 51
A.3 SCEP . 52
A.3.1 Overview . 52
A.3.2 Comparison of interface requirements of CMF and SCEP . 52
A.3.3 Comparison of Certificate Signing Request operation and PKCSreq operation. 54
A.4 EST . 54
A.4.1 Overview . 54
A.4.2 Comparison of interface requirements of CMF and EST . 54
A.4.3 Comparison of Certificate Signing Request operation and Enrolment of Clients operation . 56
A.5 ACME . 56
A.5.1 Overview . 56
A.5.2 Comparison of interface requirements of CMF and ACME . 57
A.5.3 Comparison of Register operation and Account Creation operation . 58
A.5.4 Comparison of Certificate Signing Request operation and Certificate Issuance operation . 58
A.5.5 Comparison of Deregister operation and Account Deactivation operation . 59
A.5.6 Comparison of Revoke operation and Certificate Revocation operation . 59
A.6 Analysis of solutions against the interface requirements of CMF. 60
A.6.1 Overview . 60
A.6.2 Comparison of interface requirements . 60
A.6.3 Comparison of attributes of interface . 61
A.6.4 Conclusion . 62
Annex B (informative): Mapping operations to protocol elements . 63
B.1 Overview . 63
B.2 Certificate Management interface . 63
ETSI
6 ETSI GS NFV-SOL 023 V5.3.1 (2025-09)
B.3 VNF Lifecycle Management interface . 63
B.4 Certificate Notification interface . 63
Annex C (normative): Authorization scope values . 64
C.1 Overview . 64
C.2 Certificate Management interface . 64
C.3 Certificate Notification interface . 65
Annex D (informative): Complementary material for API utilization . 66
Annex E (informative): Change history . 67
History . 69
ETSI
7 ETSI GS NFV-SOL 023 V5.3.1 (2025-09)
Intellectual Property Rights
Essential patents
IPRs essential or potentially essential to normative deliverables may have been declared to ETSI. The declarations
pertaining to these essential IPRs, if any, are publicly available for ETSI members and non-members, and can be
found in ETSI SR 000 314: "Intellectual Property Rights (IPRs); Essential, or potentially Essential, IPRs notified to
ETSI in respect of ETSI standards", which is available from the ETSI Secretariat. Latest updates are available on the
ETSI IPR online database.
Pursuant to the ETSI Directives including the ETSI IPR Policy, no investigation regarding the essentiality of IPRs,
including IPR searches, has been carried out by ETSI. No guarantee can be given as to the existence of other IPRs not
referenced in ETSI SR 000 314 (or the updates on the ETSI Web server) which are, or may be, or may become,
essential to the present document.
Trademarks
The present document may include trademarks and/or tradenames which are asserted and/or registered by their owners.
ETSI claims no ownership of these except for any which are indicated as being the property of ETSI, and conveys no
right to use or reproduce any trademark and/or tradename. Mention of those trademarks in the present document does
not constitute an endorsement by ETSI of products, services or organizations associated with those trademarks.
DECT™, PLUGTESTS™, UMTS™ and the ETSI logo are trademarks of ETSI registered for the benefit of its
Members. 3GPP™, LTE™ and 5G™ logo are trademarks of ETSI registered for the benefit of its Members and of the
3GPP Organizational Partners. oneM2M™ logo is a trademark of ETSI registered for the benefit of its Members and of ®
the oneM2M Partners. GSM and the GSM logo are trademarks registered and owned by the GSM Association.
Foreword
This Group Specification (GS) has been produced by ETSI Industry Specification Group (ISG) Network Functions
Virtualisation (NFV).
Modal verbs terminology
In the present document "shall", "shall not", "should", "should not", "may", "need not", "will", "will not", "can" and
"cannot" are to be interpreted as described in clause 3.2 of the ETSI Drafting Rules (Verbal forms for the expression of
provisions).
"must" and "must not" are NOT allowed in ETSI deliverables except when used in direct citation.
ETSI
8 ETSI GS NFV-SOL 023 V5.3.1 (2025-09)
1 Scope
The present document specifies the interfaces and reference points between CMF and VNFM to fulfil the requirements
specified in ETSI GS NFV-IFA 033 [2]. The present document analyses existing solutions for ETSI
GS NFV-IFA 033 [2] / ETSI GS NFV-IFA 026 [1] requirements. Based on the analysis results, the present document
profiles them and includes OpenAPI representations for a RESTful protocol and data model specification for Certificate
Notification interface and "Additional features" of Certificate Management interface since the subset of VNF Lifecycle
Management interface refers to the ETSI GS NFV other specifications.
2 References
2.1 Normative references
References are either specific (identified by date of publication and/or edition number or version number) or
non-specific. For specific references, only the cited version applies. For non-specific references, the latest version of the
referenced document (including any amendments) applies.
Referenced documents which are not found to be publicly available in the expected location might be found in the
ETSI docbox.
NOTE: While any hyperlinks included in this clause were valid at the time of publication, ETSI cannot guarantee
their long term validity.
The following referenced documents are necessary for the application of the present document.
[1] ETSI GS NFV-IFA 026: "Network Functions Virtualisation (NFV) Release 5; Management and
Orchestration; Architecture enhancement for Security Management Specification".
[2] ETSI GS NFV-IFA 033: "Network Functions Virtualisation (NFV) Release 5; Management and
Orchestration; Reference points related to Security Manager and Certificate Management Function
- Interface and Information Model Specification".
[3] ETSI GS NFV-SOL 002: " Network Functions Virtualisation (NFV) Release 5; Protocols and Data
Models; RESTful protocols specification for the Ve-Vnfm Reference Point".
[4] ETSI GS NFV-SOL 013: " Network Functions Virtualisation (NFV) Release 5; Protocols and Data
Models; Specification of common aspects for RESTful NFV MANO APIs".
[5] IETF RFC 4210: "Internet X.509 Public Key Infrastructure Certificate Management Protocol
(CMP)".
[6] IETF RFC 9480: "Certificate Management Protocol (CMP) Updates".
[7] IETF RFC 8141: "Uniform Resource Names (URNs)".
[8] IETF RFC 2986: "PKCS #10: Certification Request Syntax Specification Version 1.7".
[9] IETF RFC 9483: "Lightweight Certificate Management Protocol (CMP) Profile".
[10] IETF RFC 4211: "Internet X.509 Public Key Infrastructure Certificate Request Message Format
(CRMF)".
[11] ETSI GS NFV-SOL 001: "Network Functions Virtualisation (NFV) Release 5; Protocols and Data
Models; NFV descriptors based on TOSCA specification".
[12] IETF RFC 6712: "Internet X.509 Public Key Infrastructure -- HTTP Transfer for the Certificate
Management Protocol (CMP)".
ETSI
9 ETSI GS NFV-SOL 023 V5.3.1 (2025-09)
2.2 Informative references
References are either specific (identified by date of publication and/or edition number or version number) or
non-specific. For specific references, only the cited version applies. For non-specific references, the latest version of the
referenced document (including any amendments) applies.
NOTE: While any hyperlinks included in this clause were valid at the time of publication, ETSI cannot guarantee
their long term validity.
The following referenced documents may be useful in implementing an ETSI deliverable or add to the reader's
understanding, but are not required for conformance to the present document.
[i.1] ETSI GR NFV 003: "Network Functions Virtualisation (NFV); Terminology for Main Concepts in
NFV".
[i.2] IETF RFC 2510: "Internet X.509 Public Key Infrastructure Certificate Management Protocols".
[i.3] IETF RFC 8894: "Simple Certificate Enrolment Protocol".
[i.4] IETF RFC 7030: "Enrolment over Secure Transport".
[i.5] IETF RFC 8555: "Automatic Certificate Management Environment (ACME)".
[i.6] OpenAPI™ Specification.
[i.7] ETSI GS NFV-SOL 015: "Network Functions Virtualisation (NFV); Protocols and Data Models;
Specification of Patterns and Conventions for RESTful NFV-MANO APIs".
[i.8] ETSI GS NFV-IFA 007: "Network Functions Virtualisation (NFV) Release 5; Management and
Orchestration; Or-Vnfm reference point - Interface and Information Model Specification".
3 Definition of terms, symbols and abbreviations
3.1 Terms
For the purposes of the present document, the terms given in ETSI GR NFV 003 [i.1] apply.
3.2 Symbols
Void.
3.3 Abbreviations
For the purposes of the present document, the abbreviations given in ETSI GR NFV 003 [i.1] and the following apply.
NOTE: An abbreviation defined in the present document takes precedence over the definition of the same
abbreviation, if any, in ETSI GR NFV 003 [i.1].
ACME Automatic Certificate Management Environment
CA Certification Authority
CMF Certificate Management Function
CMP Certificate Management Protocol
CRL Certificate Revocation List
CSR Certificate Signing Request
DER Distinguished Encoding Rules
EST Enrolment over Secure Transport
OID Object Identifier
PSE Personal Security Environment
SCEP Simple Certificate Enrolment Protocol
ETSI
10 ETSI GS NFV-SOL 023 V5.3.1 (2025-09)
4 Overview of Certificate Management
4.1 Introduction
This clause provides an overview of certificate management interface on the reference point Cm-Vnfm specified in
ETSI GS NFV-IFA 033 [2]. The present document supports below interfaces:
1) The Certificate Management interface as specified in clause 11.2 of ETSI GS NFV-IFA 033 [2]. The
Certificate Management interface is exposed by the CMF and consumed by the VNFM. This is for the
management of VNFCI and VNF OAM certificate in delegation mode. Profiling of the existing solution are
specified in clause 4.2.1 and clause 5 of the present document, and new APIs that are not supported by existing
solution are specified in clause 5.6 by RESTful API.
2) A subset of the VNF LCM interface (operation occurrence event notifications and query VNF) exposed by the
VNFM and consumed by the CMF as specified in clause 11.3 of ETSI GS NFV-IFA 033 [2]. This is for the
management of VNFCI and VNF OAM certificate in direct mode. This interface is specified in clause 6 of the
present document.
3) Certificate Notification Service interface as introduced in clause 11.4 of ETSI GS NFV-IFA 033 [2] over the
Cm-Vnfm reference point with the VNFM as consumer of the service interface. This is specified in clause 7 of
the present document.
4.2 Overview of protocols and data models
4.2.1 Summary of CMPv2
4.2.1.1 Introduction
This clause provides an overview over CMPv2 as specified in IETF RFC 9480 [6] and IETF RFC 4210 [5] which are
analysed to the requirements on the certificate management interfaces defined in ETSI GS NFV-IFA 033 [2]. The
overview covers the high-level feature summary, involved entities, and provides how to support certificate management
interface requirements with considering CMPv2.
4.2.1.2 Feature summary
The Certificate Management Protocol version 2 (CMPv2) is an internet protocol standardized by the IETF for obtaining
digital certificates within a Public Key Infrastructure (PKI). CMPv2 provides set of features and flexibility, supporting
types of cryptography. The main purpose and features are, facilitating the automated management of digital certificates,
including issuance, updates, and revocation, which are operated between a Certificate Authority (CA) and an end entity.
Key features are:
• Self-contained Messages: CMPv2 messages can use different transport mechanisms (unlike related protocols
like EST and SCEP).
• Full Certificate Life Cycle Support: End entities can use CMPv2 to obtain certificates from a CA, request
updates, and handle revocations.
• Key Pair Generation: Typically done by the client side, but can also be done at the CA server side.
• Proof-of-Possession: Usually achieved through self-signatures of requested certificate contents, but CMPv2
supports other methods.
• Proof-of-Origin: Supported in two formats: based on a shared secret (initially) and signature-based (using pre-
existing certificates).
• Key Pair Recovery: Allows recovery of lost private keys stored by the CA.
ETSI
11 ETSI GS NFV-SOL 023 V5.3.1 (2025-09)
• Other Requests: CMPv2 supports various other request types, such as retrieving CA certificates and obtaining
PKI parameters.
CMPv2 supports messages related to certificate management as follows:
• initialization request message (ir), with ip response
• certification request message (cr), with cp response
• certification request message (p10cr), with cp response
• certificate confirmation (certConf)key pair update operation (kur/kup)
• certificate update message
• CA key pair update message
• certificate discovery message
• recovery message
• revocation messages (rr/rp)
• PSE message
• End Entity Initialization
CMPv2 messages are encoded in ASN.1 using the DER method. The protocol is independent of the transport
mechanism, ensuring end-to-end security. Examples of transport options are HTTP, HTTPS, and CoAP.
A CMPv2 protocol can be realized in several ways but all implementations shall support the basic authenticated
scheme.
4.2.1.3 Involved entities
CMPv2 has below involved entities:
• End Entities (EEs): is used here to refer to the entity to whom the certificate is issued.
• Certificate Authorities (CAs): Issue legal certificates and act as CMPv2 servers.
• Registration Authorities (RAs): Mediate between EEs and CAs.
5 Certificate Management interface
5.1 Description
This interface allows the VNFM to invoke Certificate Management operations towards the CMF.
The operations provided through this interface are:
• Register
• Certificate Signing Request
• Deregister
• Revoke
• Query Subject Info
• Query Certificate Info
ETSI
12 ETSI GS NFV-SOL 023 V5.3.1 (2025-09)
See more details of the operations defined in clause 11.2 of ETSI
...








Questions, Comments and Discussion
Ask us and Technical Secretary will try to provide an answer. You can facilitate discussion about the standard in here.
Loading comments...