millimetre Wave Transmission (mWT); Conformance Test Specification for Wireless Transport Profile for Standard SDN Northbound Interfaces; Part 2: Test Suite Structure (TSS) and Test Purposes (TP)

DGS/mWT-0029-2

General Information

Status
Not Published
Current Stage
12 - Citation in the OJ (auto-insert)
Due Date
31-Dec-2024
Completion Date
23-Dec-2024
Ref Project
Standard
ETSI GS mWT 029-2 V1.1.1 (2024-12) - millimetre Wave Transmission (mWT); Conformance Test Specification for Wireless Transport Profile for Standard SDN Northbound Interfaces; Part 2: Test Suite Structure (TSS) and Test Purposes (TP)
English language
29 pages
sale 15% off
Preview
sale 15% off
Preview

Standards Content (Sample)


GROUP SPECIFICATION
millimetre Wave Transmission (mWT);
Conformance Test Specification for Wireless Transport Profile
for Standard SDN Northbound Interfaces;
Part 2: Test Suite Structure (TSS) and Test Purposes (TP)
Disclaimer
The present document has been produced and approved by the millimetre Wave Transmission (mWT) ETSI Industry
Specification Group (ISG) and represents the views of those members who participated in this ISG.
It does not necessarily represent the views of the entire ETSI membership.

2 ETSI GS mWT 029-2 V1.1.1 (2024-12)

Reference
DGS/mWT-0029-2
Keywords
mWT, NBI, SDN, testing
ETSI
650 Route des Lucioles
F-06921 Sophia Antipolis Cedex - FRANCE

Tel.: +33 4 92 94 42 00  Fax: +33 4 93 65 47 16

Siret N° 348 623 562 00017 - APE 7112B
Association à but non lucratif enregistrée à la
Sous-Préfecture de Grasse (06) N° w061004871

Important notice
The present document can be downloaded from the
ETSI Search & Browse Standards application.
The present document may be made available in electronic versions and/or in print. The content of any electronic and/or
print versions of the present document shall not be modified without the prior written authorization of ETSI. In case of any
existing or perceived difference in contents between such versions and/or in print, the prevailing version of an ETSI
deliverable is the one made publicly available in PDF format on ETSI deliver repository.
Users should be aware that the present document may be revised or have its status changed,
this information is available in the Milestones listing.
If you find errors in the present document, please send your comments to
the relevant service listed under Committee Support Staff.
If you find a security vulnerability in the present document, please report it through our
Coordinated Vulnerability Disclosure (CVD) program.
Notice of disclaimer & limitation of liability
The information provided in the present deliverable is directed solely to professionals who have the appropriate degree of
experience to understand and interpret its content in accordance with generally accepted engineering or
other professional standard and applicable regulations.
No recommendation as to products and services or vendors is made or should be implied.
No representation or warranty is made that this deliverable is technically accurate or sufficient or conforms to any law
and/or governmental rule and/or regulation and further, no representation or warranty is made of merchantability or fitness
for any particular purpose or against infringement of intellectual property rights.
In no event shall ETSI be held liable for loss of profits or any other incidental or consequential damages.

Any software contained in this deliverable is provided "AS IS" with no warranties, express or implied, including but not
limited to, the warranties of merchantability, fitness for a particular purpose and non-infringement of intellectual property
rights and ETSI shall not be held liable in any event for any damages whatsoever (including, without limitation, damages
for loss of profits, business interruption, loss of information, or any other pecuniary loss) arising out of or related to the use
of or inability to use the software.
Copyright Notification
No part may be reproduced or utilized in any form or by any means, electronic or mechanical, including photocopying and
microfilm except as authorized by written permission of ETSI.
The content of the PDF version shall not be modified without the written authorization of ETSI.
The copyright and the foregoing restriction extend to reproduction in all media.

© ETSI 2024.
All rights reserved.
ETSI
3 ETSI GS mWT 029-2 V1.1.1 (2024-12)
Contents
Intellectual Property Rights . 4
Foreword . 4
Modal verbs terminology . 4
1 Scope . 5
2 References . 5
2.1 Normative references . 5
2.2 Informative references . 5
3 Definition of terms, symbols and abbreviations . 6
3.1 Terms . 6
3.2 Symbols . 6
3.3 Abbreviations . 6
4 Test Suite Structure (TSS) . 7
4.1 Structure for ETSI mWT Standard SDN northbound API tests . 7
5 Test Purposes (TP) . 7
5.1 Introduction . 7
5.1.1 TP definition conventions . 7
5.1.2 TP Identifier naming conventions . 7
5.1.3 Rules for the behaviour description . 7
5.1.4 Sources of TP definitions . 8
5.1.5 Mnemonics for PICS reference . 8
5.2 Test Purposes for MSDC . 8
5.3 Test Purposes for PNC . 8
5.3.1 RESTCONF support . 8
5.3.2 Black-box abstraction level. 11
5.3.3 Partially Transparent abstraction level . 12
5.3.3.1 Microwave topology inventory . 12
5.3.3.2 Ethernet topology inventory . 16
5.3.3.3 Ethernet services . 20
History . 29

ETSI
4 ETSI GS mWT 029-2 V1.1.1 (2024-12)
Intellectual Property Rights
Essential patents
IPRs essential or potentially essential to normative deliverables may have been declared to ETSI. The declarations
pertaining to these essential IPRs, if any, are publicly available for ETSI members and non-members, and can be
found in ETSI SR 000 314: "Intellectual Property Rights (IPRs); Essential, or potentially Essential, IPRs notified to
ETSI in respect of ETSI standards", which is available from the ETSI Secretariat. Latest updates are available on the
ETSI IPR online database.
Pursuant to the ETSI Directives including the ETSI IPR Policy, no investigation regarding the essentiality of IPRs,
including IPR searches, has been carried out by ETSI. No guarantee can be given as to the existence of other IPRs not
referenced in ETSI SR 000 314 (or the updates on the ETSI Web server) which are, or may be, or may become,
essential to the present document.
Trademarks
The present document may include trademarks and/or tradenames which are asserted and/or registered by their owners.
ETSI claims no ownership of these except for any which are indicated as being the property of ETSI, and conveys no
right to use or reproduce any trademark and/or tradename. Mention of those trademarks in the present document does
not constitute an endorsement by ETSI of products, services or organizations associated with those trademarks.
DECT™, PLUGTESTS™, UMTS™ and the ETSI logo are trademarks of ETSI registered for the benefit of its
Members. 3GPP™, LTE™ and 5G™ logo are trademarks of ETSI registered for the benefit of its Members and of the
3GPP Organizational Partners. oneM2M™ logo is a trademark of ETSI registered for the benefit of its Members and of ®
the oneM2M Partners. GSM and the GSM logo are trademarks registered and owned by the GSM Association.
Foreword
This Group Specification (GS) has been produced by ETSI Industry Specification Group (ISG) millimetre Wave
Transmission (mWT).
The present document is part 2 of a multi-part deliverable covering Conformance Test Specification for Wireless
Transport Profile for Standard SDN Northbound Interfaces, as identified below:
Part 1: "Implementation Conformance Statement (ICS)";
Part 2: "Test Suite Structure (TSS) and Test Purposes (TP)";
Part 3: "Abstract Test Suite (ATS) and partial Implementation eXtra Information for Testing (PIXIT)".
Modal verbs terminology
In the present document "shall", "shall not", "should", "should not", "may", "need not", "will", "will not", "can" and
"cannot" are to be interpreted as described in clause 3.2 of the ETSI Drafting Rules (Verbal forms for the expression of
provisions).
"must" and "must not" are NOT allowed in ETSI deliverables except when used in direct citation.

ETSI
5 ETSI GS mWT 029-2 V1.1.1 (2024-12)
1 Scope
The present document provides the Test Suite Structure (TSS) and Test Purposes (TP) of a multi-part conformance test
specification for the mWT Standard SDN northbound APIs for the exchange of messages, complying with the ETSI
GS mWT 024 [1] specifications, in accordance with the relevant guidance given in ISO/IEC 9646-7 [i.4].
The ISO standards for the methodology of conformance testing (ISO/IEC 9646-1 [i.1] and ISO/IEC 9646-2 [i.2]) as
well as the ETSI rules for conformance testing (ETSI ETS 300 406 [i.5]) are used as a basis for the test methodology.
2 References
2.1 Normative references
References are either specific (identified by date of publication and/or edition number or version number) or
non-specific. For specific references, only the cited version applies. For non-specific references, the latest version of the
referenced document (including any amendments) applies.
Referenced documents which are not found to be publicly available in the expected location might be found in the
ETSI docbox.
NOTE: While any hyperlinks included in this clause were valid at the time of publication, ETSI cannot guarantee
their long term validity.
The following referenced documents are necessary for the application of the present document.
[1] ETSI GS mWT 024: "millimetre Wave Transmission (mWT); Definition of a Wireless Transport
Profile for Standard SDN Northbound Interfaces".
[2] IETF RFC 8453: "Framework for Abstraction and Control of TE Networks (ACTN)".
[3] ETSI GS mWT 029-1: "millimetre Wave Transmission (mWT); Conformance Test Specification
for Wireless Transport Profile for Standard SDN Northbound Interfaces; Part 1: Implementation
Conformance Statement (ICS)".
2.2 Informative references
References are either specific (identified by date of publication and/or edition number or version number) or
non-specific. For specific references, only the cited version applies. For non-specific references, the latest version of the
referenced document (including any amendments) applies.
NOTE: While any hyperlinks included in this clause were valid at the time of publication, ETSI cannot guarantee
their long term validity.
The following referenced documents are not necessary for the application of the present document but they assist the
user with regard to a particular subject area.
[i.1] ISO/IEC 9646-1 (1994): "Information technology — Open Systems
Interconnection — Conformance testing methodology and framework — Part 1: General
concepts".
[i.2] ISO/IEC 9646-2 (1994): "Information technology — Open Systems
Interconnection — Conformance testing methodology and framework — Part 2: Abstract Test
Suite specification".
[i.3] ISO/IEC 9646-6 (1994): "Information technology — Open Systems
Interconnection — Conformance testing methodology and framework — Part 6: Protocol profile
test specification".
ETSI
6 ETSI GS mWT 029-2 V1.1.1 (2024-12)
[i.4] ISO/IEC 9646-7 (1995): "Information technology — Open Systems
Interconnection — Conformance testing methodology and framework — Part 7: Implementation
Conformance Statements".
[i.5] ETSI ETS 300 406 (1995): "Methods for testing and Specification (MTS); Protocol and profile
conformance testing specifications; Standardization methodology".
[i.6] IETF RFC 8040: "RESTCONF Protocol".
[i.7] IETF RFC 8525: "YANG Library".
[i.8] IETF RFC 8345: "A YANG Data Model for Network Topologies".
[i.9] IETF RFC 8795: "YANG Data Model for Traffic Engineering (TE) Topologies".
[i.10] draft-ietf-ccamp-mw-topo-yang-02: "A YANG Data Model for Microwave Topology".
[i.11] IETF RFC 6991: "Common YANG Data Types".
[i.12] IETF RFC 8776: "Common YANG Data Types for Traffic Engineering".
[i.13] draft-ietf-ccamp-client-signal-yang-05: "A YANG Data Model for Transport Network Client
Signals".
3 Definition of terms, symbols and abbreviations
3.1 Terms
For the purposes of the present document, the terms given in ETSI GS mWT 024 [1], ISO/IEC 9646-6 [i.3] and
ISO/IEC 9646-7 [i.4] apply.
3.2 Symbols
Void.
3.3 Abbreviations
For the purposes of the present document, the following abbreviations apply:
API Application Programming Interface
ATS Abstract Test Suite
BO Invalid Behavior
BV Valid Behaviour
CBS Committed Burst Size
CIR Committed Information Rate
EBS Excess Burst Size
EIR Excess Information Rate
ETS European Telecommunication Standard
ICS Implementation eXtra Information for Testing
MDSC Multi Domain Service Coordinator
MPI MDSC-PNC Interface
MSDC Massively Scalable Data Centers
MW Microwave
mWT millimetre Wave Transmission
N/A Not Applicable
PICS Partial Implementation Conformance Statement
PIXIT Partial Implementation eXtra Information for Testing
PNC Provisioning Network Controller
SDN Software Defined Networking
ETSI
7 ETSI GS mWT 029-2 V1.1.1 (2024-12)
TE Traffic Engineering URIUniform Resource Identifier
YANG Yet Another Next Generation
4 Test Suite Structure (TSS)
4.1 Structure for ETSI mWT Standard SDN northbound API
tests
Table 1 shows the ETSI mWT Standard SDN northbound API Test Suite Structure (TSS) defined for conformance
testing.
Table 1: TSS for mWT Standard SDN northbound API
Root Group Sub-group Category
mWT MDSC MW_TOPO Valid and Invalid
ETH_TOPO Valid
PNC MW_TOPO Valid and Invalid
ETH_TOPO Valid
5 Test Purposes (TP)
5.1 Introduction
5.1.1 TP definition conventions
The TP definition is built according to ISO/IEC 9646-6 [i.3].
5.1.2 TP Identifier naming conventions
The identifier of the TP is built according to table 2.
Table 2: TP naming convention
Identifier TP____ _ Sub-Group Category
TP = root mWT mWT Conformance tests
Multi-Domain Service
= target MDSC
Coordinator
PNC Provisioning Network Controller
= group RESTCONF RESTCONF support
ABSTRACT_BB Abstract Blackbox
PARTIALLY_TR
Partially Transparent
ANS
= sub-group MW_TOPO Microwave topology
ETH_TOPO Ethernet Topology
ETH_SERVICE Ethernet Service
= test purpose sequential number 01 to 99
= category BV Valid Behaviour tests
BO Invalid Behaviour Tests
5.1.3 Rules for the behaviour description
The description of the TP is built according to ISO/IEC 9646-6 [i.3].
ETSI
8 ETSI GS mWT 029-2 V1.1.1 (2024-12)
Being "idle" refers to the starting point of the initial device configuration. There are no pending actions, no instantiated
buffers or variables, which could disturb the execution of a test.
5.1.4 Sources of TP definitions
All TPs have been specified according to ETSI GS mWT 024 [1] and IETF RFC 8453 [2].
5.1.5 Mnemonics for PICS reference
To avoid an update of all TPs when the PICS document is changed, table 3 introduces mnemonics name and the
correspondence with the real PICS item number. The 'PICS item' as defined in ETSI GS mWT 024 [1] and IETF
RFC 8453 [2] shall be used to determine the test applicability.
Table 3: Mnemonics for PICS reference
Mnemonic PICS item
1 IUT_SDN [3] A.1/1
2 IUT_APP [3] A.1/2
3 ABSTRACT_BB [3] A.2/1
4 PARTIALLY_TRANS [3] A.2/2
5 MW_TOPO [3] A.3/1
6 ETH_TOPO [3] A.3/2
7 SERVICE_TOPO [3] A.3/3
5.2 Test Purposes for MSDC
N/A.
5.3 Test Purposes for PNC
5.3.1 RESTCONF support
TP Id TP_mWT_PNC_RESTCONF_GET_BV_01
Test Objective Verify that the IUT supports RESTCONF API request.
Reference ETSI GS mWT 024 [1], clause 5.2.1 "RESTCONF Protocol"
IETF RFC 8040 [i.6] "RESTCONF Protocol"
IETF RFC 8525 [i.7] "YANG Library"
Configuration Config_mWT_2
PICS Selection IUT_PNC and RESTCONF and SEC_TLS
Initial Conditions
with {
the IUT is idle
}
Expected Behaviour
ensure that {
when {
the IUT receives a vRequestGet containing
uri indicating value "/restconf/data/ietf-yang-library:modules-state"
from the TEST_SYSTEM entity
} then {
the IUT sends a r200 containing
headers containing
content_type indicating value "application/yang-data+xml",
body containing
modules_state containing
name_ indicating value "ietf-yang-library:modules-state",
modules containing
non empty list
to the TEST_SYSTEM entity
}
}
ETSI
9 ETSI GS mWT 029-2 V1.1.1 (2024-12)
TP Id TP_mWT_PNC_RESTCONF_GET_BV_02
Test Objective Verify that the IUT supports the basic YANG data models.
Reference ETSI GS mWT 024 [1], clause 5.2.1 "RESTCONF Protocol"
ETSI GS mWT 024 [1], clause 5.2.2 "YANG Version"
IETF RFC 8040 [i.6] "RESTCONF Protocol"
IETF RFC 8525 [i.7] "YANG Library"
Configuration Config_mWT_2
PICS Selection
IUT_PNC and RESTCONF and SEC_TLS
Initial Conditions
with {
the IUT is idle
}
Expected Behaviour
ensure that {
when {
the IUT receives a vRequestGet containing
uri indicating value "/restconf/data/ietf-yang-library:modules-state"
from the TEST_SYSTEM entity
} then {
the IUT sends a r200 containing
headers containing
content_type indicating value "application/yang-data+xml",
body containing
modules_state containing
name_ indicating value "ietf-yang-library:modules-state",
modules containing
entry containing
name_ indicating value "ietf-datastores",
revision indicating value "2018-02-14",
schema indicating value
"https://localhost:443/restconf/data/modules/ietf-datastores/2018-02-14",
namespace indicating value "urn:ietf:params:xml:ns:yang:ietf-
datastores",
conformance_type indicating value "import",
entry containing
name_ indicating value "ietf-inet-types",
revision indicating value "2013-07-15",
schema indicating value
"https://localhost:443/restconf/data/modules/ietf-inet-types/2013-07-15",
namespace indicating value "urn:ietf:params:xml:ns:yang:ietf-inet-
types",
conformance_type indicating value "import",
entry containing
name_ indicating value "ietf-interfaces",
revision indicating value "2018-02-20",
schema indicating value
"https://localhost:443/restconf/data/modules/ietf-interfaces/2018-02-20",
namespace indicating value "urn:ietf:params:xml:ns:yang:ietf-
interfaces",
conformance_type indicating value "import",
entry containing
name_ indicating value "ietf-ip",
revision indicating value "2018-02-22",
schema indicating value
"https://localhost:443/restconf/data/modules/ietf-ip/2018-02-22",
namespace indicating value "urn:ietf:params:xml:ns:yang:ietf-ip",
conformance_type indicating value "import",
entry containing
name_ indicating value "ietf-network-instance",
revision indicating value "2019-01-21",
schema indicating value
"https://localhost:443/restconf/data/modules/ietf-network-instance/2019-01-21",
namespace indicating value "urn:ietf:params:xml:ns:yang:ietf-network-
instance",
conformance_type indicating value "import",
entry containing
name_ indicating value "ietf-restconf",
revision indicating value "2017-01-26",
schema indicating value
"https://localhost:443/restconf/data/modules/ietf-restconf/2017-01-26",
namespace indicating value "urn:ietf:params:xml:ns:yang:ietf-
restconf",
conformance_type indicating value "implement",
entry containing
name_ indicating value "ietf-yang-types",
revision indicating value "2013-07-15",
ETSI
10 ETSI GS mWT 029-2 V1.1.1 (2024-12)
schema indicating value
"https://localhost:443/restconf/data/modules/ietf-restconf/2017-01-26",
namespace indicating value "urn:ietf:params:xml:ns:yang:ietf-
restconf",
conformance_type indicating value "import",
entry containing
name_ indicating value "ietf-yang-library",
revision indicating value "2019-01-04",
schema indicating value
"https://localhost:443/restconf/data/modules/ietf-yang-types/2013-07-15",
namespace indicating value "urn:ietf:params:xml:ns:yang:ietf-yang-
types",
conformance_type indicating value "implement"
to the TEST_SYSTEM entity
}
}
TP Id TP_mWT_PNC_RESTCONF_GET_BV_03
Test Objective
Verify that the IUT provides the list of supported ETSI GS mWT 024 [1] YANG data models.
Reference ETSI GS mWT 024 [1], clause 5.2.2.2 "Common YANG data models"
ETSI GS mWT 024 [1], clause 5.2.2.3 "YANG Data Models at the Microwave MPI"
ETSI GS mWT 024 [1], clause 5.2.2.4 "Hierarchical relationship among YANG data models"
Configuration Config_mWT_2
PICS Selection IUT_PNC and RESTCONF and SEC_TLS
Initial Conditions
with {
the IUT is idle
}
Expected Behaviour
ensure that {
when {
the IUT receives a vRequestGet containing
uri indicating value "/restconf/data/ietf-yang-library:modules-state"
from the TEST_SYSTEM entity
} then {
the IUT sends a r200 containing
body containing
modules_state containing
modules containing
entry containing
name_ indicating value "ietf-microwave-topology",
revision indicating value "2021-10-12",
schema indicating value "draft-ietf-ccamp-mw-topo-yang-02",
namespace indicating value "",
conformance_type indicating value "implement",
entry containing
name_ indicating value "ietf-eth-te-topology",
revision indicating value "2019-11-18",
schema indicating value "draft-ietf-ccamp-eth-client-te-topo-yang-01",
namespace indicating value "",
conformance_type indicating value "implement",
entry containing
name_ indicating value "idraft-ietf-ccamp-client-signal-yang-06",
revision indicating value "",
schema indicating value "draft-ietf-ccamp-client-signal-yang-06",
namespace indicating value "",
conformance_type indicating value ""
to the TEST_SYSTEM entity
}
}
ETSI
11 ETSI GS mWT 029-2 V1.1.1 (2024-12)
5.3.2 Black-box abstraction level
TP Id TP_mWT_PNC_BB_MW_TOPO_GET_BV_01
Test Objective Verify that the IUT does not provide any MW network topology.
Reference ETSI GS mWT 024 [1], clause 4.3.2
ETSI GS mWT 024 [1], clause A.2.3
IETF RFC 8345 [i.8] "A YANG Data Model for Network Topologies"
IETF RFC 8795 [i.9] "YANG Data Model for Traffic Engineering (TE) Topologies"
Configuration Config_mWT_2
PICS Selection IUT_PNC and RESTCONF and SEC_TLS and ABSTRACT_BB
Initial Conditions
with {
the IUT is idle
}
Expected Behaviour
ensure that {
when {
the IUT receives a vRequestGet containing
uri indicating value "/restconf/data/ietf-network:networks"
from the TEST_SYSTEM entity
} then {
the IUT sends a r200 containing
headers containing
content_type indicating value "application/yang-data+xml",
body containing
networks containing
networksList containing
name_ indicating value any_value,
networks containing
network_id indicating value any_value,
network_types containing
not te_topology
,
node_id indicating value any_value,
termination_points indicating value any_value,
links indicating value any_value

to the TEST_SYSTEM entity
}
}
TP Id TP_mWT_PNC_BB_MW_TOPO_GET_BV_01
Test Objective Verify that the IUT provides a network list containing only one node.
Reference ETSI GS mWT 024 [1], clause 4.3.2
ETSI GS mWT 024 [1], clause A.2.3
IETF RFC 8345 [i.8] "A YANG Data Model for Network Topologies"
IETF RFC 8795 [i.9] "YANG Data Model for Traffic Engineering (TE) Topologies"
Configuration
Config_mWT_2
PICS Selection
IUT_PNC and RESTCONF and SEC_TLS and ABSTRACT_BB
Initial Conditions
with {
the IUT is idle
}
Expected Behaviour
ensure that {
when {
the IUT receives a vRequestGet containing
uri indicating value "/restconf/data/ietf-network:networks"
from the TEST_SYSTEM entity
} then {
the IUT sends a r200 containing
headers containing
content_type indicating value "application/yang-data+xml",
body containing
networks containing
networksList containing
one network node
to the TEST_SYSTEM entity
}
}
ETSI
12 ETSI GS mWT 029-2 V1.1.1 (2024-12)
5.3.3 Partially Transparent abstraction level
5.3.3.1 Microwave topology inventory
TP Id TP_mWT_PNC_PT_MW_TOPO_GET_BV_01
Test Objective Verify that the IUT provides the MW network topology for all networks with mandatory ETSI
GS mWT 024 [1] data elements subset.
Reference ETSI GS mWT 024 [1], clause 4.3.3
ETSI GS mWT 024 [1], clause A.2.2
IETF RFC 8345 [i.8] "A YANG Data Model for Network Topologies"
IETF RFC 8795 [i.9] "YANG Data Model for Traffic Engineering (TE) Topologies"
draft-ietf-ccamp-mw-topo-yang-02 [i.10] "A YANG Data Model for Microwave Topology"
Configuration Config_mWT_2
PICS Selection IUT_PNC and RESTCONF and SEC_TLS and ABSTRACT_PT and MW_TOPO
Initial Conditions
with {
the IUT is idle and
the IUT having discovered several MW ethernet networks topologies
}
Expected Behaviour
ensure that {
when {
the IUT receives a vRequestGet containing
uri indicating value "/restconf/data/ietf-network:networks/topologyId/mw-native-
topology",
headers containing
content_type indicating value "application/yang-data+xml"
from the TEST_SYSTEM entity
} then {
the IUT sends a r200 containing
headers containing
content_type indicating value "application/yang-data+xml",
body containing
networks containing
networksList containing
name_ indicating value any_value,
networks containing
network_id indicating value any_value,
network_types containing
te_topology containing
mw_topology containing
mw_tp_choice indicating value any_value
,
node_id indicating value any_value,
termination_points indicating value any_value,
links indicating value any_value

to the TEST_SYSTEM entity
}
}
TP Id TP_mWT_PNC_PT_MW_TOPO_GET_BV_02
Test Objective Verify that the IUT provides the MW network topology for a specific network with mandatory ETSI
GS mWT 024 [1] data elements subset.
Reference ETSI GS mWT 024 [1], clause 4.3.3
ETSI GS mWT 024 [1], clause A.2.2.1
IETF RFC 8345 [i.8] "A YANG Data Model for Network Topologies"
IETF RFC 8795 [i.9] "YANG Data Model for Traffic Engineering (TE) Topologies"
Configuration Config_mWT_2
PICS Selection
IUT_PNC and RESTCONF and SEC_TLS and ABSTRACT_PT and MW_TOPO
Initial Conditions
with {
the IUT is idle and
the IUT having discovered a network topology NETWORK_TOPO
}
ETSI
13 ETSI GS mWT 029-2 V1.1.1 (2024-12)
Expected Behaviour
ensure that {
when {
the IUT receives a vRequestGet containing
uri indicating value "/restconf/data/ietf-microwave-topology/ietf-
network:networks/network={NETWORK_ID/topologyId/mw-native-topology",
headers containing
content_type indicating value "application/yang-data+xml"
from the TEST_SYSTEM entity
} then {
the IUT sends a r200 containing
headers containing
content_type indicating value "application/yang-data+xml",
body containing
networks containing
network_id indicating value NETWORK_ID,
network_types containing
te_topology containing
mw_topology containing
mw_tp_choice indicating value any_value
,
node_id indicating value any_value,
termination_points indicating value any_value,
links indicating value any_value

to the TEST_SYSTEM entity
}
}
TP Id TP_mWT_PNC_PT_MW_TOPO_GET_BO_01
Test Objective Verify that the IUT replies with an error code when the request is malformed.
Reference ETSI GS mWT 024 [1], clause 4.3.3
ETSI GS mWT 024 [1], clause 5.3.2 "Exception Handling"
ETSI GS mWT 024 [1], clause A.2.2
IETF RFC 8345 [i.8] "A YANG Data Model for Network Topologies"
IETF RFC 8795 [i.9] "YANG Data Model for Traffic Engineering (TE) Topologies"
Configuration Config_mWT_2
PICS Selection IUT_PNC and RESTCONF and SEC_TLS and ABSTRACT_PT and MW_TOPO
Initial Conditions
with {
the IUT is idle and
the IUT having discovered a network topology NETWORK_TOPO
}
Expected Behaviour
ensure that {
when {
the IUT receives a vRequestGet containing
uri indicating value "/restconf/data/networks" // Malformed URI
from the TEST_SYSTEM entity
} then {
the IUT sends a r400
to the TEST_SYSTEM entity
}
}
TP Id
TP_mWT_PNC_PT_MW_TOPO_GET_BO_02
Test Objective Verify that the IUT replies with an error code when the network identifier is unknown.
Reference ETSI GS mWT 024 [1], clause 4.3.3
ETSI GS mWT 024 [1], clause 5.3.2 "Exception Handling"
ETSI GS mWT 024 [1], clause A.2.2
IETF RFC 8345 [i.8] "A YANG Data Model for Network Topologies"
IETF RFC 8795 [i.9] "YANG Data Model for Traffic Engineering (TE) Topologies"
Configuration Config_mWT_2
PICS Selection IUT_PNC and RESTCONF and SEC_TLS and ABSTRACT_PT and MW_TOPO
ETSI
14 ETSI GS mWT 029-2 V1.1.1 (2024-12)
Initial Conditions
with {
the IUT is idle and
the IUT having discovered a network topology NETWORK_TOPO
}
Expected Behaviour
ensure that {
when {
the IUT receives a vRequestGet containing
uri indicating value "/restconf/data/ietf-
network:networks/network={UNKNOWN_NETWORK_ID/topologyId/mw-native-topology"
from the TEST_SYSTEM entity
} then {
the IUT sends a r404
to the TEST_SYSTEM entity
}
}
TP Id TP_mWT_PNC_PT_MW_NODE_GET_BV_01
Test Objective Verify that the IUT provides the MW network topology for all nodes with mandatory ETSI
GS mWT 024 [1] data elements subset.
Reference ETSI GS mWT 024 [1], clause 4.3.3
ETSI GS mWT 024 [1], clause A.2.2.1
IETF RFC 8345 [i.8] "A YANG Data Model for Network Topologies"
IETF RFC 8795 [i.9] "YANG Data Model for Traffic Engineering (TE) Topologies"
draft-ietf-ccamp-mw-topo-yang-02 [i.10] "A YANG Data Model for Microwave Topology"
Configuration Config_mWT_2
PICS Selection IUT_PNC and RESTCONF and SEC_TLS and ABSTRACT_PT and MW_TOPO
Initial Conditions
with {
the IUT is idle and
the IUT having discovered several MW ethernet networks topologies
}
Expected Behaviour
ensure that {
when {
the IUT receives a vRequestGet containing
uri indicating value "/restconf/data/ietf-microwave-topology/ietf-
network:networks/network={NETWORK_ID/node/topologyId/mw-native-topology"
from the TEST_SYSTEM entity
} then {
the IUT sends a r200 containing
headers containing
content_type indicating value "application/yang-data+xml",
body containing
networks containing
networksList containing
name_ indicating value any_value,
networks containing
network_id indicating value any_value,
network_types containing
te_topology containing
mw_native_topology indicating value any_value
,
node_id indicating value any_value,
termination_points indicating value any_value,
links indicating value any_value

to the TEST_SYSTEM entity
}
}
ETSI
15 ETSI GS mWT 029-2 V1.1.1 (2024-12)
TP Id TP_mWT_PNC_PT_MW_NODE_GET_BV_02
Test Objective Verify that the IUT provides the MW network topology for a specific node with mandatory ETSI
GS mWT 024 [1] data elements subset.
Reference ETSI GS mWT 024 [1], clause 4.3.3
ETSI GS mWT 024 [1], clause A.2.2.1
IETF RFC 8345 [i.8] "A YANG Data Model for Network Topologies"
IETF RFC 8795 [i.9] "YANG Data Model for Traffic Engineering (TE) Topologies"
draft-ietf-ccamp-mw-topo-yang-02 [i.10] "A YANG Data Model for Microwave Topology"
Configuration
Config_mWT_2
PICS Selection IUT_PNC and RESTCONF and SEC_TLS and ABSTRACT_PT and MW_TOPO
Initial Conditions
with {
the IUT is idle and
the IUT having discovered several MW ethernet networks topologies
}
Expected Behaviour
ensure that {
when {
the IUT receives a vRequestGet containing
uri indicating value "/restconf/data/ietf-microwave-topology/ietf-
network:networks/network={NETWORK_ID/node={NODE_ID}/topologyId/mw-native-topology"
from the TEST_SYSTEM entity
} then {
the IUT sends a r200 containing
headers containing
content_type indicating value "application/yang-data+xml",
body containing
networks containing
networksList containing
name_ indicating value any_value,
networks containing
network_id indicating value NETWORK_ID,
network_types containing
te_topology containing
mw_native_topology indicating value any_value
,
node_id indicating value NODE_ID,
termination_points indicating value any_value,
links indicating value any_value

to the TEST_SYSTEM entity
}
}
TP Id TP_mWT_PNC_PT_MW_NODE_GET_BO_01
Test Objective Verify that the IUT replies with an error code when the node identifier is unknown.
Reference
ETSI GS mWT 024 [1] clause 4.3.3
ETSI GS mWT 024 [1] clause 5.3.2 "Exception Handling"
ETSI GS mWT 024 [1] clause A.2.2
IETF RFC 8345 [i.8] "A YANG Data Model for Network Topologies"
IETF RFC 8795 [i.9] "YANG Data Model for Traffic Engineering (TE) Topologies"
draft-ietf-ccamp-mw-topo-yang-02 [i.10] "A YANG Data Model for Microwave Topology"
Configuration Config_mWT_2
PICS Selection IUT_PNC and RESTCONF and SEC_TLS and ABSTRACT_PT and MW_TOPO
Initial Conditions
with {
the IUT is idle and
the IUT having discovered several MW ethernet networks topologies
}
Expected Behaviour
ensure that {
when {
the IUT receives a vRequestGet containing
uri indicating value "/restconf/data/ietf-microwave-topology/ietf-
network:networks/network={NETWORK_ID/node={UNKNOWN_NODE_ID}/topologyId/mw-native-topology"
from the TEST_SYSTEM entity
} then {
the IUT sends a r404
to the TEST_SYSTEM entity
}
}
ETSI
16 ETSI GS mWT 029-2 V1.1.1 (2024-12)
5.3.3.2 Ethernet topology inventory
TP Id TP_mWT_PNC_PT_ETH_TOPO_GET_BV_01
Test Objective Verify that the IUT provides the Ethernet network topology for all networks with mandatory ETSI
GS mWT 024 [1] data elements subset.
Reference ETSI GS mWT 024 [1], clause 4.3.3
ETSI GS mWT 024 [1], clause A.2.2
IETF RFC 8345 [i.8] "A YANG Data Model for Network Topologies"
IETF RFC 8795 [i.9] "YANG Data Model for Traffic Engineering (TE) Topologies"
draft-ietf-ccamp-mw-topo-yang-02 [i.10] "A YANG Data Model for Microwave Topology"
Configuration Config_mWT_2
PICS Selection IUT_PNC and RESTCONF and SEC_TLS and ABSTRACT_PT and ETH_TOPO
Initial Conditions
with {
the IUT is idle and
the IUT having discovered several MW ethernet networks topologies
}
Expected Behaviour
ensure that {
when {
the IUT receives a vRequestGet containing
uri indicating value "/restconf/data/ietf-network:networks",
headers containing
content_type indicating value "application/yang-data+xml"
from the TEST_SYSTEM entity
} then {
the IUT sends a r200 containing
headers containing
content_type indicating value "application/yang-data+xml",
body containing
networks containing
networksList containing
name_ indicating value any_value,
networks containing
network_id indicating value any_value,
network_types containing
te_topology containing
mw_topology containing
mw_tp_choice indicating value any_value
,
node_id indicating value any_value,
termination_points indicating value any_value,
links indicating value any_value

to the TEST_SYSTEM entity
}
}
TP Id TP_mWT_PNC_PT_ETH_TOPO_GET_BV_02
Test Objective
Verify that the IUT provides the Ethernet network topology for a specific network with mandatory
ETSI GS mWT 024 [1] data elements subset.
Reference ETSI GS mWT 024 [1], clause 4.3.3
ETSI GS mWT 024 [1], clause A.1.2
IETF RFC 8345 [i.8] "A YANG Data Model for Network Topologies"
IETF RFC 8795 [i.9] "YANG Data Model for Traffic Engineering (TE) Topologies"
Configuration
Config_mWT_2
PICS Selection
IUT_PNC and RESTCONF and SEC_TLS and ABSTRACT_PT and ETH_TOPO
Initial Conditions
with {
the IUT is idle and
the IUT having discovered a network topology NETWORK_TOPO
}
ETSI
17 ETSI GS mWT 029-2 V1.1.1 (2024-12)
Expected Behaviour
ensure that {
when {
the IUT receives a vRequestGet containing
uri indicating value "/restconf/data/ietf-network:networks/network={NETWORK_ID",
headers containing
content_type indicating value "application/yang-data+xml"
from the TEST_SYSTEM entity
} then {
the IUT sends a r200 containing
headers containing
content_type indicating value "application/yang-data+xml",
body containing
networks containing
network_id indicating value NETWORK_ID,
network_types containing
te_topology indicating value any_value,
node_id indicating value any_value,
termination_points indicating value any_value,
links indicating value any
...

Questions, Comments and Discussion

Ask us and Technical Secretary will try to provide an answer. You can facilitate discussion about the standard in here.

Loading comments...