ETSI TR 103 858 V1.1.1 (2026-03)
Core Network and Interoperability Testing (INT); Autonomic/Autonomous IPv6 based 5G Networks: powered by ETSI GANA Multi-Layer Autonomics & Multi-Layer AI-Algorithms and IPv6 Capabilities
Core Network and Interoperability Testing (INT); Autonomic/Autonomous IPv6 based 5G Networks: powered by ETSI GANA Multi-Layer Autonomics & Multi-Layer AI-Algorithms and IPv6 Capabilities
DTR/INT-009001
General Information
- Status
- Not Published
- Technical Committee
- INT AFI - Evolution of Management towards Autonomic Future Internet
- Current Stage
- 12 - Completion
- Due Date
- 10-Mar-2026
- Completion Date
- 03-Mar-2026
Buy Documents
ETSI TR 103 858 V1.1.1 (2026-03) - Core Network and Interoperability Testing (INT); Autonomic/Autonomous IPv6 based 5G Networks: powered by ETSI GANA Multi-Layer Autonomics & Multi-Layer AI-Algorithms and IPv6 Capabilities
Frequently Asked Questions
ETSI TR 103 858 V1.1.1 (2026-03) is a standard published by the European Telecommunications Standards Institute (ETSI). Its full title is "Core Network and Interoperability Testing (INT); Autonomic/Autonomous IPv6 based 5G Networks: powered by ETSI GANA Multi-Layer Autonomics & Multi-Layer AI-Algorithms and IPv6 Capabilities". This standard covers: DTR/INT-009001
DTR/INT-009001
ETSI TR 103 858 V1.1.1 (2026-03) is available in PDF format for immediate download after purchase. The document can be added to your cart and obtained through the secure checkout process. Digital delivery ensures instant access to the complete standard document.
Standards Content (Sample)
TECHNICAL REPORT
Core Network and Interoperability Testing (INT);
Autonomic/Autonomous IPv6 based 5G Networks:
powered by ETSI GANA Multi-Layer Autonomics &
Multi-Layer AI-Algorithms and IPv6 Capabilities
2 ETSI TR 103 858 V1.1.1 (2026-03)
Reference
DTR/INT-009001
Keywords
5G, artificial intelligence, autonomic networking,
cyber security, enhanced mobile broadband, IPv6,
security, self-management
ETSI
650 Route des Lucioles
F-06921 Sophia Antipolis Cedex - FRANCE
Tel.: +33 4 92 94 42 00 Fax: +33 4 93 65 47 16
Siret N° 348 623 562 00017 - APE 7112B
Association à but non lucratif enregistrée à la
Sous-Préfecture de Grasse (06) N° w061004871
Important notice
The present document can be downloaded from the
ETSI Search & Browse Standards application.
The present document may be made available in electronic versions and/or in print. The content of any electronic and/or
print versions of the present document shall not be modified without the prior written authorization of ETSI. In case of any
existing or perceived difference in contents between such versions and/or in print, the prevailing version of an ETSI
deliverable is the one made publicly available in PDF format on ETSI deliver repository.
Users should be aware that the present document may be revised or have its status changed,
this information is available in the Milestones listing.
If you find errors in the present document, please send your comments to
the relevant service listed under Committee Support Staff.
If you find a security vulnerability in the present document, please report it through our
Coordinated Vulnerability Disclosure (CVD) program.
Notice of disclaimer & limitation of liability
The information provided in the present deliverable is directed solely to professionals who have the appropriate degree of
experience to understand and interpret its content in accordance with generally accepted engineering or
other professional standard and applicable regulations.
No recommendation as to products and services or vendors is made or should be implied.
No representation or warranty is made that this deliverable is technically accurate or sufficient or conforms to any law
and/or governmental rule and/or regulation and further, no representation or warranty is made of merchantability or fitness
for any particular purpose or against infringement of intellectual property rights.
In no event shall ETSI be held liable for loss of profits or any other incidental or consequential damages.
Any software contained in this deliverable is provided "AS IS" with no warranties, express or implied, including but not
limited to, the warranties of merchantability, fitness for a particular purpose and non-infringement of intellectual property
rights and ETSI shall not be held liable in any event for any damages whatsoever (including, without limitation, damages
for loss of profits, business interruption, loss of information, or any other pecuniary loss) arising out of or related to the use
of or inability to use the software.
Copyright Notification
No part may be reproduced or utilized in any form or by any means, electronic or mechanical, including photocopying and
microfilm except as authorized by written permission of ETSI.
The content of the PDF version shall not be modified without the written authorization of ETSI.
The copyright and the foregoing restriction extend to reproduction in all media.
© ETSI 2026.
All rights reserved.
ETSI
3 ETSI TR 103 858 V1.1.1 (2026-03)
Contents
Intellectual Property Rights . 5
Foreword . 5
Modal verbs terminology . 5
Executive Summary . 6
Introduction . 6
1 Scope . 8
2 References . 8
2.1 Normative references . 8
2.2 Informative references . 8
3 Definition of terms, symbols and abbreviations . 12
3.1 Terms . 12
3.2 Symbols . 12
3.3 Abbreviations . 12
4 Principles for Autonomic Networking and Autonomic Management & Control (AMC), and
Enablers . 15
5 Use Cases for AI/ML and Autonomics in E2E IPv6 based 5G Networks in general; and Mappings
to GANA DEs that help implement particular Use Case . 16
5.1 Autonomic Management and Control (AMC) of Network Slices . 16
5.2 Auto-Discovery and Auto-Configuration (Self-Configuration) Use Case . 17
5.3 Autonomic Mobility Management and Control Use Case. 17
5.4 Autonomic Routing Management and Control Use Case . 17
5.5 Autonomic Forwarding Management Use Case . 18
5.6 Autonomic QoS and QoE Management and Control Use Case . 18
5.7 Autonomic Monitoring Management and Control Use Case . 19
5.8 Autonomic Security Management and Control Use Case . 19
5.9 Autonomic Fault Management Use Case . 20
5.10 Autonomic Resilience & Survivability Management Use Case . 20
5.11 Autonomic Performance Management Use Case . 20
6 IPv6-Only based E2E 5G Networks: E2E Aspects of IPv6 in 5G and Reference Architecture
Scenarios for Consideration; Implications on GANA Autonomics . 21
6.1 Background of SRv6 technology and the motivation in the context of Network Automation . 21
6.2 Value of IPv6 in 5G network, and consideration of GANA Multi-Layer Autonomics in the picture . 21
6.3 Slicing in packet networks. 23
6.3.1 Network Slicing high level architecture. 23
6.3.2 SRv6 based network slicing . 24
6.3.3 SR-based network programming . 26
6.3.4 Application-aware Networking . 27
6.3.5 SRv6 and SDWAN . 27
6.4 IPv6-only in 5G SA user plane based on 464XLAT/NAT64+DNS64 . 27
6.5 Network Automation and SDN . 29
6.6 IPv6/SRv6 Operations Administration and Maintenance (OAM) tools and Automation (mapping with
GANA) . 30
6.7 Other ETSI IPE Reference Architecture Scenarios for consideration . 33
7 GANA Autonomic Management & Control (AMC) for IPv6 Protocols; IPv6 Capabilities that
enable to Design & Build Autonomic 5G Networks and Services . 39
7.1 Overview on GANA Autonomic Management & Control (AMC) of IPv6 Protocols in E2E 5G
Networks, with consideration for Use Cases of AI/ML in the AMC . 39
7.2 IPv6 Capabilities that enable to Design and Build Autonomic 5G Networks and Services . 41
8 Framework for Implementing Autonomic/Autonomous IPv6 based 5G Networks, powered by
GANA Multi-Layer AI/ML & Multi-Layer AMC and IPv6 Capabilities . 43
ETSI
4 ETSI TR 103 858 V1.1.1 (2026-03)
8.1 Overview about the Framework defined by the present document . 43
8.2 GANA Multi-Layer Autonomics & AI/ML in IPv6-Only based 5G E2E Reference Architecture
Scenarios, with Consideration of the Example Autonomics Use Cases . 44
8.2.1 DEs to MEs Mappings, and Autonomic Management & Control of IPv6 Protocols by GANA DEs . 44
8.2.2 GANA for Access Network (Fixed Access, RAN, Other Access Networks) . 45
8.2.3 GANA Autonomics for Multi Layer Transport SDN Architecture . 47
8.2.4 GANA for 5G Service Based Architecture (SBA) . 49
8.2.5 GANA Autonomics for MEC Architecture . 49
9 Executing PoCs Program on the Framework for Implementing Autonomic/Autonomous IPv6
based 5G/6G Networks powered by GANA, AI, and IPv6 . 50
10 Ongoing PoCs Program on GANA in ETSI 5G PoC Implementations by the Industry . 51
11 Conclusion and Further Work . 51
Annex A: Supplementary Information . 52
Annex B: Bibliography . 55
History . 56
ETSI
5 ETSI TR 103 858 V1.1.1 (2026-03)
Intellectual Property Rights
Essential patents
IPRs essential or potentially essential to normative deliverables may have been declared to ETSI. The declarations
pertaining to these essential IPRs, if any, are publicly available for ETSI members and non-members, and can be
found in ETSI SR 000 314: "Intellectual Property Rights (IPRs); Essential, or potentially Essential, IPRs notified to
ETSI in respect of ETSI standards", which is available from the ETSI Secretariat. Latest updates are available on the
ETSI IPR online database.
Pursuant to the ETSI Directives including the ETSI IPR Policy, no investigation regarding the essentiality of IPRs,
including IPR searches, has been carried out by ETSI. No guarantee can be given as to the existence of other IPRs not
referenced in ETSI SR 000 314 (or the updates on the ETSI Web server) which are, or may be, or may become,
essential to the present document.
Trademarks
The present document may include trademarks and/or tradenames which are asserted and/or registered by their owners.
ETSI claims no ownership of these except for any which are indicated as being the property of ETSI, and conveys no
right to use or reproduce any trademark and/or tradename. Mention of those trademarks in the present document does
not constitute an endorsement by ETSI of products, services or organizations associated with those trademarks.
DECT™, PLUGTESTS™, UMTS™ and the ETSI logo are trademarks of ETSI registered for the benefit of its
Members. 3GPP™, LTE™ and 5G™ logo are trademarks of ETSI registered for the benefit of its Members and of the
3GPP Organizational Partners. oneM2M™ logo is a trademark of ETSI registered for the benefit of its Members and of ®
the oneM2M Partners. GSM and the GSM logo are trademarks registered and owned by the GSM Association.
Foreword
This Technical Report (TR) has been produced by ETSI Technical Committee Core Network and Interoperability
Testing (INT).
Modal verbs terminology
In the present document "should", "should not", "may", "need not", "will", "will not", "can" and "cannot" are to be
interpreted as described in clause 3.2 of the ETSI Drafting Rules (Verbal forms for the expression of provisions).
"must" and "must not" are NOT allowed in ETSI deliverables except when used in direct citation.
ETSI
6 ETSI TR 103 858 V1.1.1 (2026-03)
Executive Summary
The main target of the present document is to serve as a Framework or Guide for Implementing
Autonomic/Autonomous IPv6 based E2E 5G Networks, by leveraging the ETSI GANA Multi-Layer AI/ML and
Multi-Layer Autonomic Management and Control Model and IPv6 Capabilities and its Extensions that enable to Build
Autonomic Networks. ETSI GANA is an Architectural Reference Model for Autonomic Networking, Cognitive
Networking and Self-Management of Networks and Services standardized by ETSI in ETSI TS 103 195-2 [i.2].
Through the Framework, software modules (called Autonomic Functions) for enabling automated management,
autonomic management (self-management) and self-adaptive control of the network, called GANA
Decision-making-Elements (DEs), and their associated Algorithms (including analytics, optimization and AI/ML
algorithms), can be innovated and implemented for the network. GANA DEs are meant to drive control-loops within
Network Elements/Functions (NEs or NFs) of the 5G network infrastructure and/or drive control-loops at the higher
level of abstraction for self-management functionality that is positioned within the outer Management and Control
realm of a 5G Network Infrastructure - within a platform called the GANA Knowledge Plane (KP) Platform that uses
complex AI algorithms to dynamically and adaptively (re)-configure the network and services using management and
control systems such as OSS/BSS, SDN Controllers, Orchestrators, MANO stacks, etc. DE algorithms are not subject to
standardization as they provide for the space for innovation and DE and Algorithm supplier differentiations. Examples
of Autonomic Functions (i.e. GANA DEs) are: QoS-management-DE, Security-management-DE,
Mobility-management-DE, Fault-management-DE, Resilience & Survivability-DE, Service & Application
management-DE, Forwarding-management-DE, Routing-management-DE, Monitoring-management-DE, Generalized
Control Plane management-DE.
The Framework presented in the present document prescribes how to utilize IPv6 Capabilities and emerging IPv6
Extensions in implementing GANA DEs powered Autonomic/Autonomous IPv6 based E2E 5G Network. Innovators
obtain guidance on the types of GANA DEs that should be designed to auto-configure and dynamically
(autonomically/adaptively) orchestrate and (re)-configure various Managed Entities (MEs), including IPv6 Protocols as
MEs of the of 5G Network, as driven by Service or Slice provisioning, or adaptively to meet certain objectives. DEs
also provide the means to intelligently adapt the network to various kinds of detected and predicted situations and
challenges the autonomic 5G network may experience during its operation.
Introduction
Artificial Intelligence Models (AI Models) are enablers for advanced intelligence in the management and control
operations now strongly required for the evolving and future networks such as 5G Networks. AI algorithms bring
benefits to diverse aspects in development and deployment of AI exhibiting systems such as Autonomic (Closed-Loop)
and Cognitive 5G networks and their associated Autonomic Management and Control systems. European
Telecommunications Standards Institute (ETSI) Technical Committee (TC) INT/AFI Working Group (WG) has
recently published the de-facto standard on the Generic Autonomic Networking Architecture (GANA) Reference
Model - An Architectural Reference Model for Autonomic Networking, Cognitive Networking and Self-Management
of Networks and Services in which AI plays a role in autonomic management and control of networks and services [i.2].
ETSI TS 103 195-2 [i.2] defines an Intelligent Management and Control Functional Block called GANA Knowledge
Plane (KP) that is an integral part of Management and Control Systems for the network. GANA KP Platform host
complex AI powered network analytics functions that are performed by interworking modules for autonomic
(closed-loop) decision-making and execution called GANA Decision-making-Elements (DEs).
The KP DEs run as software in the Knowledge Plane (KP) Platform and drive self-* operations such as
self-adaptation, self-optimization, self-monitoring, self-protection and self-defense objectives for the network and
services by programmatically (re)-configuring Managed Entities (MEs) in the network infrastructure through various
means possible. The means to program MEs include NorthBound Interfaces available at the Operations Support
Systems (OSS), Service Orchestrator, Domain Orchestrator, Software Defined Networking (SDN) controller, Element
Management System/Network Management System (EMS/NMS), Network Functions Virtualisation (NFV)
Orchestrator, etc. KP DEs are powered by Artificial Intelligence (AI) algorithms such as Machine Learning (ML), Deep
Learning (DL), computational intelligence, etc., such that they execute as AI models or components that embed
AI Models [i.2], [i.3], [i.7], [i.6] and [i.11].
ETSI
7 ETSI TR 103 858 V1.1.1 (2026-03)
ETSI TC INT/ AFI WG has established that E2E Autonomic (Closed-Loop) Service and Security Assurance should be
achievable through the Federation of GANA Knowledge Planes (KPs) Platforms that implement components for
Autonomic Management and Control (AMC) intelligence for specific network segments and domains. The ETSI
GANA Framework enables to define and standardize such a framework. Autonomics by the GANA Knowledge Plane
(KP) for a particular network segment/domain is complemented by lower level autonomics introduced in Network
Elements/Functions (NEs/NFs) of the particular network segment under the responsibility of the KP, such that the KP
policy-controls the lower level autonomics introduced in NEs/NFs. The E2E federation of KPs for the various network
segments/domains and their policy-controlling of lower levels autonomics in the NEs/NFs of their respective network
segments enable to achieve the complementary multi-layer autonomics. The complementary multi-layer autonomics and
the federations of KP Platforms should realize (achieve) Holistic Multi-Domain State Correlation and resources
programming by the GANA KPs for the network segments/domains such as the Access, X-Haul (Fronthaul, Midhaul
and Backhaul), and Core Networks, etc. While such an E2E Federation of KP Platforms for multiple network segments
(as domains) has to be primarily considered within a single network operator administrative domain, the E2E Federation
of KPs may be extended to even span multiple network operators' or enterprises' network administrative domains.
ETSI TC INT/AFI WG Specifications such as ETSI TR 103 404 [i.5], ETSI TR 103 495 [i.13], ETSI TR 103 473 [i.4],
and ETSI TR 103 747 [i.63] provide the answer to the question of how to implement GANA-defined autonomic
manager components (called autonomic functions, i.e. GANA DEs) that implement control-loops in physical Network
Elements/Functions (NEs/NFs) and in Virtualised Network Functions (VNFs). This includes answers to how to
complement the NE/NF Level autonomic manager components with autonomic manager components defined to operate
in the realm outside of NEs/NFs (the realm of management and control systems for particular network architectures),
i.e. in the realm called the GANA Knowledge Plane (KP).
ETSI TC INT/AFI WG is also running a Proof-Of-Concept (PoC) Program on 5G Network Slices Creation,
Autonomic & Cognitive Management & End-to-End (E2E) Orchestration; with Closed-Loop (Autonomic)
Service Assurance of 5G Slices, as described in clause 10 of the present document.
ETSI
8 ETSI TR 103 858 V1.1.1 (2026-03)
1 Scope
The present document is a Framework (Guide) to Implementing Autonomic/Autonomous IPv6 based 5G Networks, by
leveraging the ETSI GANA Multi-Layer AI / Multi-Layer Autonomic Management and Control Model and IPv6
Capabilities & Extensions that enable to Build Autonomic Networks. The Framework prescribes how to introduce
software components called Autonomic Functions (ETSI GANA Decision-making-Elements (DEs)), e.g. Autonomic-
QoS-Management-DE, Autonomic-Security-Management-DE, etc. in the 5G Architecture and its associated
Management and Control Architecture. The DEs and their associated Algorithms (including analytics, optimization and
AI algorithms) are meant to drive control-loops within Network Functions of the 5G network infrastructure and/or drive
control-loops at the higher level of abstraction for self-management functionality that is positioned within the outer
Management and Control realm of a 5G Network Infrastructure - within a platform called the GANA Knowledge Plane
(KP) Platform. The Framework also serves to:
• prescribe how to leverage certain IPv6 Capabilities in enabling Autonomic Functions (called
Decision-making-Elements (DEs) in the present document) of the Autonomic 5G network to auto-discover
each other, auto-discover various context information, monitoring data, and to exchange DE-to-DE control
messages among each other for their collaborative operations in the Self-Driving/Self-Management Operations
of the 5G network(s);
• provide Guidance to Innovators of DEs and their associated Autonomics Algorithms, on the types of GANA
DEs that should be designed to auto-configure and dynamically (autonomically) orchestrate and (re)-configure
various IPv6 Protocols of the of 5G Network as driven by Service or Slice provisioning, or adaptively to meet
certain objectives.
2 References
2.1 Normative references
Normative references are not applicable in the present document.
2.2 Informative references
References are either specific (identified by date of publication and/or edition number or version number) or
non-specific. For specific references, only the cited version applies. For non-specific references, the latest version of the
referenced document (including any amendments) applies.
NOTE: While any hyperlinks included in this clause were valid at the time of publication, ETSI cannot guarantee
their long-term validity.
The following referenced documents may be useful in implementing an ETSI deliverable or add to the reader's
understanding, but are not required for conformance to the present document.
[i.1] ETSI White Paper No.16: "GANA - Generic Autonomic Networking Architecture - Reference
Model for Autonomic Networking, Cognitive Networking and Self-Management of Networks and
Services".
[i.2] ETSI TS 103 195-2 (V1.1.1): "Autonomic network engineering for the self-managing Future
Internet (AFI); Generic Autonomic Network Architecture; Part 2: An Architectural Reference
Model for Autonomic Networking, Cognitive Networking and Self-Management".
[i.3] White Paper No.1 of the ETSI 5G PoC: "C-SON Evolution for 5G, Hybrid SON Mappings to the
ETSI GANA Model, and achieving E2E Autonomic (Closed-Loop) Service Assurance for 5G
Network Slices by Cross-Domain Federated GANA Knowledge Planes".
[i.4] ETSI TR 103 473 (V1.1.2): "Evolution of management towards Autonomic Future Internet (AFI);
Autonomicity and Self-Management in the Broadband Forum (BBF) Architectures".
ETSI
9 ETSI TR 103 858 V1.1.1 (2026-03)
[i.5] ETSI TR 103 404: "Network Technologies (NTECH); Autonomic network engineering for the
self-managing Future Internet (AFI); Autonomicity and Self-Management in the Backhaul and
Core network parts of the 3GPP Architecture".
[i.6] White Paper No.3 of the ETSI 5G PoC: "Programmable Traffic Monitoring Fabrics that enable
On-Demand Monitoring and Feeding of Knowledge into the ETSI GANA Knowledge Plane for
Autonomic Service Assurance of 5G Network Slices; and Orchestrated Service Monitoring in
NFV/Clouds".
[i.7] White Paper No.2 of the ETSI 5G PoC: "ONAP Mappings to the ETSI GANA Model; Using
ONAP Components to Implement GANA Knowledge Planes and Advancing ONAP for
Implementing ETSI GANA Standard's Requirements; and C-SON - ONAP Architecture".
[i.8] ETSI TS 129 520 (V16.6.0): "5G; 5G System; Network Data Analytics Services; Stage 3 (3GPP
TS 29.520 version 16.6.0 Release 16)".
[i.9] ETSI TS 128 533 (V15.0.0): "5G; Management and orchestration; Architecture framework (3GPP
TS 28.533 version 15.0.0 Release 15)".
[i.10] NGMN Alliance: "5G End-to-End Architecture Framework v3.0.8".
[i.11] White Paper No.4 of the ETSI 5G PoC: "ETSI GANA as Multi-Layer Artificial Intelligence (AI)
Framework for Implementing AI Models for Autonomic Management & Control (AMC) of
Networks and Services; and Intent-Based Networking (IBN) via GANA Knowledge Planes
(KPs)".
[i.12] ETSI GS AFI 002 (V1.1.1): "Autonomic network engineering for the self-managing Future
Internet (AFI); Generic Autonomic Network Architecture (An Architectural Reference Model for
Autonomic Networking, Cognitive Networking and Self-Management)".
[i.13] ETSI TR 103 495: "Network Technologies (NTECH); Autonomic network engineering for the
self-managing Future Internet (AFI); Autonomicity and Self-Management in Wireless
Ad-hoc/Mesh Networks: Autonomicity-enabled Ad-hoc and Mesh Network Architectures".
[i.14] Ranganai Chaparadza, Michal Wodczak, Tayeb Ben Meriem, Paolo De Lutiis, Nikolay
Tcholtchev, Laurent Ciavaglia: "Standardization of resilience & survivability, and autonomic
fault-management, in evolving and future networks: An ongoing initiative recently launched in
th
ETSI", In proceedings of 2013 9 International Conference on the Design of Reliable
Communication Networks (DRCN 2013), ISBN 9781479900497, 4-7 March 2013, Budapest,
Hungary.
[i.15] IETF RFC 9386: "IPv6 Deployment Status".
[i.16] Reliance Jio: "IPv6-only adoption challenges and standardization requirements", 2020.
[i.17] T-Mobile US: "Going IPv6-only", 2018.
[i.18] Carl A. Sunshine: "Source Routing In Computer Networks", ACM SIGCOMM Computer
Communication Review Volume 7, Issue 1, January 1977, pp. 29–33.
[i.19] IETF RFC 8754: "IPv6 Segment Routing Header (SRH)", March 2020.
[i.20] IETF RFC 8986: "Segment Routing over IPv6 (SRv6) Network Programming", February 2021.
[i.21] ETSI GR IPE 001 (V1.1.1) (2021-08): "IPv6 Enhanced Innovation (IPE); Gap Analysis".
[i.22] ETSI TS 123 501 (V16.6.0) (2020-10): "5G; System architecture for the 5G System (5GS) (3GPP
TS 23.501 version 16.6.0 Release 16)".
[i.23] IETF RFC 5120: "M-ISIS: Multi Topology (MT) Routing in Intermediate System to Intermediate
Systems (IS-ISs)", February 2008.
[i.24] IETF RFC 4915: "Multi-Topology (MT) Routing in OSPF", June 2007.
[i.25] IETF draft-ietf-teas-ietf-network-slices: "A Framework for IETF Network Slices", January 2023
(work in progress).
ETSI
10 ETSI TR 103 858 V1.1.1 (2026-03)
[i.26] IETF RFC 9350: "IGP Flexible Algorithm", February 2023.
[i.27] IETF RFC 9256: "Segment Routing Policy Architecture", July 2022.
[i.28] IETF RFC 5440: "Path Computation Element (PCE) Communication Protocol (PCEP)",
March 2009.
[i.29] ETSI White Paper No. 16: "GANA - Generic Autonomic Networking Architecture".
[i.30] IETF RFC 9313: "Pros and Cons of IPv6 Transition Technologies for IPv4-as-a-Service
(IPv4aaS)", October 2022.
[i.31] IETF RFC 6146: "Stateful NAT64: Network Address and Protocol Translation from IPv6 Clients
to IPv4 Servers", April 2011.
[i.32] IETF RFC 6147: "DNS64: DNS Extensions for Network Address Translation from IPv6 Clients to
IPv4 Servers", April 2011.
[i.33] IETF RFC 6877: "464XLAT: Combination of Stateful and Stateless Translation", April 2013.
[i.34] IETF RFC 6333: "Dual-Stack Lite Broadband Deployments Following IPv4 Exhaustion",
August 2011.
[i.35] ETSI TS 103 878: "Core Network and Interoperability Testing (INT); Network Interoperability
Test Description for IPv6-only services over 5G".
[i.36] ETSI GR IP6 010: "IPv6-based SDN and NFV; Deployment of IPv6-based SDN and NFV".
[i.37] IETF RFC 9341: "Alternate-Marking Method", December 2022.
[i.38] IETF RFC 9342: "Clustered Alternate-Marking Method", December 2022.
[i.39] IETF RFC 6241: "Network Configuration Protocol (NETCONF)", June 2011.
[i.40] IETF RFC 7752: "North-Bound Distribution of Link-State and Traffic Engineering (TE)
Information Using BGP", March 2016.
[i.41] IETF RFC 8571: "IGP Traffic Engineering Performance Metric Extensions", March 2019.
[i.42] IETF draft-ietf-idr-segment-routing-te-policy: "Advertising Segment Routing Policies in BGP",
July 2022 (work in progress).
[i.43] R. Chaparadza, S. Papavassiliou, S. Soulhi and J. Ding: "The Self-Managing Future Internet
powered by the current IPv6 and extensions to IPv6 towards "IPv6++" — A viable roadmap
Scenario for the Internet Evolution Path", 2010 IEEE™ Globecom Workshops, 2010, pp. 551-556,
doi: 10.1109/GLOCOMW.2010.5700381.
[i.44] Chaparadza, R., Petre, R., Prakash, A., Németh, F., Kukliński, S., Starschenko, A. (2011): "IPv6
and Extended IPv6 (IPv6++) Features That Enable Autonomic Network Setup and Operation", In:
Szabó, R., Zhu, H., Imre, S., Chaparadza, R. (eds) Access Networks. AccessNets 2010. Lecture
Notes of the Institute for Computer Sciences, Social Informatics and Telecommunications
Engineering, vol. 63. Springer, Berlin, Heidelberg.
[i.45] A. Starschenko, N. Tcholtchev, A. Prakash, I. Schieferdecker and R. Chaparadza:
th
"Auto-configuration of OSPFv3 routing in fixed IPv6 networks", 2015 7 International Congress
on Ultra Modern Telecommunications and Control Systems and Workshops (ICUMT), 2015,
pp. 196-205, doi: 10.1109/ICUMT.2015.7382427.
[i.46] Ranganai Chaparadza, Tayeb Ben Meriem, Benoit Radier, Szymon Szott, Michal Wódczak, Arun
Prakash, Jianguo Ding, Said Soulhi, Andrej Mihailovic: "Implementation Guide for the ETSI AFI
GANA model: A Standardized Reference Model for Autonomic Networking, Cognitive
Networking and Self-Management", 2013 IEEE™ Globecom Workshops (GC Wkshps), 2013,
pp. 935-940, doi: 10.1109/GLOCOMW.2013.6825110.
ETSI
11 ETSI TR 103 858 V1.1.1 (2026-03)
[i.47] N. Tcholtchev, A. Prakash, I. Schieferdecker, R. Chaparadza and R. Petre: "Auto-Collaboration for
optimal network resource utilization in fixed IPv6 networks", 2012 IEEE™ Globecom
Workshops, 2012, pp. 807-812, doi: 10.1109/GLOCOMW.2012.6477679.
[i.48] Kaldanis, V., Benko, P., Asztalos, D., Simon, C., Chaparadza, R., Katsaros, G. (2011):
"Methodology towards Integrating Scenarios and Testbeds for Demonstrating Autonomic/Self-
managing Networks and Behaviors Required in Future Networks", In: Szabó, R., Zhu, H., Imre, S.,
Chaparadza, R. (eds) Access Networks. AccessNets 2010. Lecture Notes of the Institute for
Computer Sciences, Social Informatics and Telecommunications Engineering, vol 63. Springer,
Berlin, Heidelberg.
[i.49] Prakash, A., Starschenko, A., Chaparadza, R. (2011): "Auto-discovery and Auto-configuration of
Routers in an Autonomic Network", In: Szabó, R., Zhu, H., Imre, S., Chaparadza, R. (eds) Access
Networks. AccessNets 2010. Lecture Notes of the Institute for Computer Sciences, Social
Informatics and Telecommunications Engineering, vol. 63. Springer, Berlin, Heidelberg.
[i.50] Rétvári, G., Németh, F., Chaparadza, R., Szabó, R. (2009): "OSPF for Implementing Self-adaptive
Routing in Autonomic Networks: A Case Study", In: Strassner, J.C., Ghamri-Doudane, Y.M. (eds)
Modelling Autonomic Communications Environments. MACE 2009. Lecture Notes in
Computer Science, vol. 5844. Springer, Berlin, Heidelberg.
[i.51] Zafeiropoulos, A., Liakopoulos, A., Davy, A., Chaparadza, R. (2010): "Monitoring within an
Autonomic Network: A GANA Based Network Monitoring Framework", In: Dan, A., Gittler, F.,
Toumani, F. (eds) Service-Oriented Computing. ICSOC/ServiceWave 2009 Workshops.
ServiceWave ICSOC 2009 2009. Lecture Notes in Computer Science, vol. 6275. Springer, Berlin,
Heidelberg.
[i.52] Szymon Szott, Janusz Gozdecki, Katarzyna Kosek-Szott, Krzysztof Loziak, Marek Natkaniec,
Michal Wagrowski, Ranganai Chaparadza: "Enabling autonomicity in wireless mesh networks
with the ETSI AFI GANA reference model", International Journal of Network Management, First
published: 01 August 2017.
[i.53] "Evolution of the current IPv6 towards IPv6++ (IPv6 with Autonomic Flavours", In: International
Engineering Consortium (IEC) Annual Review of Communications, vol. 60 (December 2008).
[i.54] Georgios Aristomenopoulos, Timotheos Kastrinogiannis, Zhaojun Li & Symeon Papavassiliou:
"An Autonomic QoS-centric Architecture for Integrated Heterogeneous Wireless
Networks", Mobile Netw Appl 16, 490–504 (2011).
[i.55] G. Aristomenopoulos, T. Kastrinogiannis, Z. Li, M. Wilson, M. González Juan, A. Lozano-López
Jose, Y. Li, V. Kaldanis, S. Papavassiliou: "Autonomic mobility and resource management over an
integrated wireless environment — A GANA oriented architecture", 2010 IEEE™ Globecom
Workshops, Miami, FL, USA, 2010, pp. 545-550, doi: 10.1109/GLOCOMW.2010.5700379.
[i.56] Z. Li: "An autonomic hierarchical mobility management framework for 3GPP heterogeneous
networks", 2010 Future Network & Mobile Summit, Florence, Italy, 2010, pp. 1-8.
[i.57] A. Jaron, P. Pangalos, A. Mihailovic, A.H. Aghvami: "Proactive autonomic load uniformisation
with mobility management for wireless Internet Protocol (IP) access networks", Source: Volume 1,
Issue 4, December 2012, p. 229 - 238: doi: 10.1049/iet-net.2011.0009, Print ISSN 2047-4954,
Online ISSN 2047-4962.
[i.58] A. Liakopoulos, A. Zafeiropoulos, C. Marinos, M. Grammatikou, N. Tcholtchev and P. Gouvas:
"Applying distributed monitoring techniques in autonomic networks", 2010 IEEE™ Globecom
Workshops, Miami, FL, USA, 2010, pp. 498-502, doi: 10.1109/GLOCOMW.2010.5700369.
[i.59] European Commission (EC) funded FP7: "Exposing the Features in IP version Six protocols that
can be exploited/extended for the purposes of designing/building Autonomic Networks and
Services".
[i.60] IETF draft-chaparadza-6man-igcp-00: "IETF Autonomic Networking Integrated Model and
Approach (anima)".
[i.61] IETF draft-chaparadza-6man-igcp-00.txt: "ICMPv6 based Generic Control Protocol (IGCP)".
ETSI
12 ETSI TR 103 858 V1.1.1 (2026-03)
[i.62] European Commission funded -EFIPSANS-FP7-IP Project: Deliverable-D3.2: "Advanced
Network Services in Autonomic IPv6 Networking: Performance Analysis and Evaluation", issued
on 31.12.2009 (accessed November 2023).
[i.63] ETSI TR 103 747 (V1.1.1): "Core Network and Interoperability Testing (INT/WG AFI); Federated
GANA Knowledge Planes (KPs) for Multi-Domain Autonomic Management & Control (AMC) of ®
Slices in the NGMN 5G End-to-End Architecture Framework".
[i.64] EANTC: "MPLS SDN Interoperability Test 2023", SRv6 test.
[i.65] ETSI GR IPE 005 (V1.1.1): "IPv6 Enhanced Innovation (IPE); 5G Transport over IPv6 and
SRv6".
[i.66] ETSI TR 103 626: "Autonomic network engineering for the self-managing Future Internet (AFI);
An Instantiation and Implementation of the Generic Autonomic Network Architecture (GANA)
Model onto Heterogeneous Wireless Access Technologies using Cognitive Algorithms".
[i.67] ETSI White Paper No. 35: "IPv6 Best Practices, Benefits, Transition Challenges and the Way
Forward", First edition, August 2020.
[i.68] oneM2M TR-436: "Access & Home Network OAM Automation/Intelligence", Issue: 1 Issue Date:
February 2021.
[i.69] IETF RFC 8992 (2021): "Autonomic IPv6 Edge Prefix Management in Large-Scale Networks".
[i.70] IETF RFC 8990: "GeneRic Autonomic Signalling Protocol (GRASP)".
[i.71] Recommendation ITU-T Y.3324: "Requirements and architectural framework for autonomic
management and control of IMT-2020 networks".
[i.72] IETF RFC 7596: "Lightweight 4over6: An Extension to the Dual-Stack Lite Architecture".
[i.73] IETF RFC 7599: "Mapping of Address and Port using Translation (MAP-T)".
[i.74] IETF RFC 7597: "Mapping of Address and Port with Encapsulation (MAP-E)".
3 Definition of terms, symbols and abbreviations
3.1 Terms
Void.
3.2 Symbols
Void.
3.3 Abbreviations
For the purposes of the present document, the following abbreviations apply:
rd
3GPP 3 Generation Partnership Project
5G SA 5G StandAlone
AcN Autonomic Network
AFI Autonomic Future Internet
AFTR Address Family Transition Router
AGG AGgregation Gateway
AI Artificial Intelligence
AMC Autonomic Management & Control
AMF Access and Mobility Management Function
AN Autonomous Network
ETSI
13 ETSI TR 103 858 V1.1.1 (2026-03)
ANIMA Autonomic Networking Integrated Model and Approach
API Application Programming Interfaces
APN Application - aware Networking
APN6 Application - aware IPv6 Networking
AS Autonomous System
ASN Autonomous System Number
ATS Abstract Test Suite
BBF BroadBand Forum
BFD Bidirectional Forwarding Detection
BGP Border Gateway Protocol
BGP-LS Border Gateway Protocol Link-State
CAPEX CAPital EXpenditure
CLAT Client-side NAT
CLI Command Line Interface
CPE Customer Premises Equipment
CSG1 Communication Systems Group
C-SON Centralized Self Organizing Network
DC Data Centre
DE Decision making Element
DL DownLink
DNS Domain Name System
DS-lite Dual Stack lite
D-SON Distributed - Self Organizing Network
E2E End-to-End
EC European Community
ECMP Equal-Cost Multi-Path
EMS Element Management System
EPC Evolved Packet Core
FBB Fixed BroaBand
FlexE Flexible Ethernet
FP7 Seventh Framework Programme
FW FireWall
GANA Generic Autonomic Network Architecture
GRASP GeneRic Autonomic Signalling Protocol
IANA Internet Assigned Numbers Authority
ICMP Internet Control Message Protocol
ICT Information and Communications Technology
IFIT In-situ Flow Information Telemetry
IGCP ICMPv6 based Generic Control Protocol
IGP Interior Gateway Protocol
IKE Internet Key Exchange
IMS IP Multimedia Subsystem
IoT Internet of Thing
IP Internet Protocol
IPE IPv6 Enhanced innovation
IS-IS Intermediate System-to-Intermediate System
ISP Internet Service Provider
KP Knowledge Plane
KP DE Knowledge Plane Decision-making Element
KPI Key Performance Indicator
MANO Management and Orchestration
MAP-E Mapping of Address and Port with Encapsulation
MAPE-K Monitor-Analyse-Plan-Execute over a shared Knowledge
MAP-T Mapping of Address and Port using Translation
MBB Mobile BoradBand
MBTS Model-Based Translation Service
MDAS Management Data Analytics Service
ME Managed Entity
MEC Mobile Edge Computing
ML Machine Learning
mMTC massive Machine Type Communications
MPLS MultiProtocol Label Switching
ETSI
14 ETSI TR 103 858 V1.1.1 (2026-03)
NAT Network Address Translation
NB NorthBound
NE Network Element
NF Network Function
NFV Network Function Virtualisation
NGMN Next Generation Mobile Networks
NSSF Network Slice Selection Function
NWDAF NetWork Data Analytics Function
NWDAS NetWork Data Analytic Service
OAM Operations Administration and Maintenance
ODA Open Digital Architecture
ONIX Overlay Network for Information eXchange
OPEX OPerating EXpenses
O-RAN Open RAN
OSe Operating System embedded
OSPF Open Shortest Path First
OSS Operations Support Systems
PE Provider Edge
PLAT Provider-side NAT
PoC Proof of Concept
Pre-AGG Pre-Aggregation Gateway
QoE Quality of Experience
QoS Quality of Service
RAN Radio Access Network
RAN Radio Access Network
RIC RAN Intelligent Controllers
RR Route Reflectors
SBA Service Based Architecture
SDN Software Defined Networks
SDO Standards Development Organizations
SDWAN Software-Defined Wide Area Network
SEG Secure Gateway
SID Segment Identifier
SLA Service Level Agreement
SMF Session Management Function
SNMP Simple Network Management Protocol
SON Self Organizing Networks
SPAN Switched Port Analyser
SPF Shortest Path First
SR-BE Segment Routing Best Effort
SRH Segment Routing Header
SR-PCE Segment Routing - Path Computation Engine
SR-TE Segment Routing - Traffic Engineering
TAP Test Access Points
TE Traffic Engineering
TLV Type-Length-Value
TWAMP Two-Way Active Measurement Protocol
UE User Equipment
UPF User Plane Function
URLLC Ultra Reliable and Low Latency Communications
VNF Virtual Network Function
VRF Virtual Routing and Forwarding
WAN Wide Area Network
WG Working Group
YANG Yet Another Next Generation
ETSI
15 ETSI TR 103 858 V1.1.1 (2026-03)
4 Principles for Autonomic Networking and Autonomic
Management & Control (AMC), and Enablers
This clause refers to clause 4 of ETSI TR 103 747 [i.63].
The Generic Autonomic Networking Architecture (GANA) Reference Model serves as a standardized architectural
framework for autonomic networking, cognitive networking, and self-management of networks and services. It defines
a hierarchy of Functional Blocks (FBs) that implements a control-loop as the core driver of the self-management, their
reference points, and messaging protocols, supporting both micro-level (within network elements) and macro-level
(network-wide) autonomic control loops.
Central to GANA is the Knowledge Plane (KP), which orchestrates intelligent management and control through key
components such as network-level Decision-making Elements (DEs), the ONIX overlay for distributed information
exchange, and the Model-Based Translation Service (MBTS) for protocol-agnostic communication between DEs and
network elements. GANA's hybrid approach allows implementers flexibility in deploying autonomic logic either
centrally (macro-autonomics) or in a distributed manner (micro-autonomics), and is
...




Questions, Comments and Discussion
Ask us and Technical Secretary will try to provide an answer. You can facilitate discussion about the standard in here.
Loading comments...