ASTM F1757-96(2015)
(Guide)Standard Guide for Digital Communication Protocols for Computerized Systems
Standard Guide for Digital Communication Protocols for Computerized Systems
SIGNIFICANCE AND USE
4.1 This guide is intended to provide an understanding of the wide range of communication protocols standards, allowing the user to understand better their applicability to shipboard networks and marine platform computerized systems. For computerized networks and systems, communication protocols are necessary for integrating various system devices, providing functionality between dissimilar subnetworks, or for enabling remote connections, either pier side or through geophysical communication technologies.
4.2 The wide variety and scope of digital communication protocol standards adds greatly to the complex decision process for specifying compatible protocols for system applications and related devices for the myriad of potential shipboard systems. However, the user must identify the initial networking requirements, so once the network protocols under evaluation are well understood, the decision process should determine the appropriate network protocols. Therefore, this guide is intended to reduce the complexity involved with protocol selection and implementation.
4.3 Network protocols define an agreed, quantifiable entity, or set of rules, by which user computers, system networks, and internetworking devices communicate and exchange information. Communication protocols specify essential networking guidelines, such as physical interface connections, or data format and control operations between two communicating computers. Ship and marine digital communication protocol requirements are no different than their land-based networked counterparts. Both require standardized protocol selection, in various protocol categories, including LAN standards, WAN protocols, LAN/WAN protocols, network management, wiring hub configurations/operations, hardware platforms, operating systems, and network applications.
SCOPE
1.1 The principal content of this guide provides a road map to implement a communication network applicable to ship and marine computer systems by:
1.1.1 Examining the relationship of digital communication protocols as a network technological infrastructure,
1.1.2 Outlining the basic building blocks of network topologies and transmission techniques associated with the implementation of transmission media in a network environment; and,
1.1.3 Identifying operating system and environments.
1.2 Using the Open System Interconnection (OSI) model, which provides a layered approach to network functionality and evaluation, common network communications protocols are identified and characterized in this guide according to lower and upper layer protocols corresponding to their degree and type of functionality.
1.3 Although it is desirable that network users, designers, and administrators recognize and understand every possible networking protocol, it is not possible to know the intimate details of every protocol specification. Accordingly, this guide is not intended to address fully every hardware and software protocol ever developed for commercial use, which spans a period of about 25 years. Instead, the user of this guide will be introduced to a brief overview of the majority of past and present protocols which may comprise a ship or marine internetwork, to include Local Area Networks (LANs), Wide Area Networks (WANs), and related hardware and software that provide such network interoperability and data transfer.
1.4 While this guide provides an understanding of the wide range of communication protocols, the user is recommended to consult the reference material for acquiring a more comprehensive understanding of individual communication protocols. However, by examining the basic functions of protocols and reviewing the protocol characterization criteria identified in this guide, the user will be more apt to understanding other protocols not mentioned or addressed herein.
General Information
Buy Standard
Standards Content (Sample)
NOTICE: This standard has either been superseded and replaced by a new version or withdrawn.
Contact ASTM International (www.astm.org) for the latest information
Designation: F1757 − 96 (Reapproved 2015) An American National Standard
Standard Guide for
Digital Communication Protocols for Computerized
Systems
This standard is issued under the fixed designation F1757; the number immediately following the designation indicates the year of
original adoption or, in the case of revision, the year of last revision. A number in parentheses indicates the year of last reapproval. A
superscript epsilon (´) indicates an editorial change since the last revision or reapproval.
1. Scope this guide, the user will be more apt to understanding other
protocols not mentioned or addressed herein.
1.1 The principal content of this guide provides a road map
to implement a communication network applicable to ship and
2. Referenced Documents
marine computer systems by:
2.1 ASTM Standards:
1.1.1 Examining the relationship of digital communication
E1013 Terminology Relating to Computerized Systems
protocols as a network technological infrastructure,
(Withdrawn 2000)
1.1.2 Outlining the basic building blocks of network topolo-
2.2 ANSI Standards:
gies and transmission techniques associated with the imple-
X3T9.5 High Speed Local Network
mentation of transmission media in a network environment;
X3.139 Fiber Distributed Data Interface (FDDI) – Token
and,
Ring Media Access Control (MAC)
1.1.3 Identifying operating system and environments.
X3.148 Fiber Distributed Data Interface (FDDI)– Token
1.2 Using the Open System Interconnection (OSI) model,
Ring Physical Layer Protocol (PHY)
which provides a layered approach to network functionality
X3.166 Fiber Distributed Data Interface (FDDI) – Token
and evaluation, common network communications protocols
Ring Physical Layer Medium Dependent (PMD)
areidentifiedandcharacterizedinthisguideaccordingtolower
X3.172 American National Standard Dictionary for Infor-
and upper layer protocols corresponding to their degree and
mation Systems
type of functionality.
2.3 IEEE Standards:
1.3 Although it is desirable that network users, designers,
100 Standard Dictionary for Electrical and Electronic Terms
and administrators recognize and understand every possible
610 Standard Glossary for Software Engineering Terminol-
networking protocol, it is not possible to know the intimate
ogy
details of every protocol specification. Accordingly, this guide
610.7 Standard Glossary of Computer Networking Termi-
is not intended to address fully every hardware and software
nology
protocol ever developed for commercial use, which spans a
802.1 High Level Interface (Internetworking)
period of about 25 years. Instead, the user of this guide will be
802.2 Logical Link Control
introduced to a brief overview of the majority of past and
802.3 CSMA/CD Medium Access Control
present protocols which may comprise a ship or marine
802.4 Token Bus Medium Access Control
internetwork, to include Local Area Networks (LANs), Wide
802.5 Token Ring Medium Access Control
Area Networks (WANs), and related hardware and software
802.6 Metropolitan Area Networking
that provide such network interoperability and data transfer.
802.8 Fiber Optic Technical Advisory Group
802.9 Local and Metropolitan Area Networks: Integrated
1.4 While this guide provides an understanding of the wide
range of communication protocols, the user is recommended to Services (IS) LAN Interface at the Medium Access
Control (MAC) and Physical (PHY) Layers
consult the reference material for acquiring a more compre-
hensive understanding of individual communication protocols.
However, by examining the basic functions of protocols and
For referenced ASTM standards, visit the ASTM website, www.astm.org, or
reviewing the protocol characterization criteria identified in
contact ASTM Customer Service at service@astm.org. For Annual Book of ASTM
Standards volume information, refer to the standard’s Document Summary page on
the ASTM website.
1 3
This guide is under the jurisdiction of ASTM Committee F25 on Ships and The last approved version of this historical standard is referenced on
Marine Technology and is the direct responsibility of Subcommittee F25.05 on www.astm.org.
Computer Applications. Available fromAmerican National Standards Institute (ANSI), 25 W. 43rd St.,
Current edition approved May 1, 2015. Published June 2015. Originally 4th Floor, New York, NY 10036, http://www.ansi.org.
approved in 1996. Last previous edition approved in 2008 as F1757 – 96 (2008). Available from Institute of Electrical and Electronics Engineers, Inc. (IEEE),
DOI: 10.1520/F1757-96R15. 445 Hoes Ln., P.O. Box 1331, Piscataway, NJ 08854-1331, http://www.ieee.org.
Copyright © ASTM International, 100 Barr Harbor Drive, PO Box C700, West Conshohocken, PA 19428-2959. United States
F1757 − 96 (2015)
803.5 RFC 1042
RFC 1157 Simple Network Management Protocol
2.4 ISO Standards:
RFC 1201
7498 Information Processing Systems–Open Systems Inter-
connection–Basic Reference Model
9040/9041 Virtual Terminal (VT) 3. Terminology
8831/8832 Job Transfer and Manipulation (JTM)
3.1 Definitions:
8571/8572 File Transfer Access Management (FTAM)
3.1.1 The terminology used in this guide is defined in
9595/9596 Common Management Information Service/
Terminology E1013, IEEE 610, and ANSI X3.172, with the
Protocol (CMIP)
following additions defined in 3.2.
8823 Connection Oriented Presentation Protocol
3.2 Definitions of Terms Specific to This Standard:
8327 Connection Oriented Session Protocol
3.2.1 bridge, n—a device that interconnects local or remote
8073 Connection Oriented Transport Protocol
networks no matter what network protocol that is, TCP/IP or
8473 Connectionless Network Service
IPX, are involved. Bridges form a single logical network.
8208 Packet Level Protocol
8802-2 Logical Link Control 3.2.2 hub, n—a central location for the attachment of cables
9314-2 FDDI from nodes and other network components.
8802-3 CSMA/CD (Bus)
3.2.3 internetwork, n—a collection of LANs using different
8802-4 Token Bus
network operating systems that are connected to form a larger
8802-5 Token Ring
network.
7776 Link Access Protocol/Link Access Protocol-Balanced
3.2.4 LAN (local area network), n—a data communication
(LAP/LAPB)
system consisting of a collection of interconnected computers,
7809 High-Level Data Link Control (HDLC)
sharing applications, data and peripherals.
2.5 ITU Standards:
X.25 Packet Level Protocol
3.2.5 network operating system (NOS), n—the software for
X.226 Connection Oriented Presentation Protocol
a network that runs in a file server and control access to files
X.225 Connection Oriented Session Protocol
and other resources from multiple users.
X.224 Connection Oriented Transport Protocol
3.2.6 node(s), n—any intelligent device connected to the
2.6 CCITT Standards:
network. This includes terminal servers, host computers, and
V.35
any other devices, such as printers and terminals, that are
X.21 (BIS) Interface Between Data Terminal Equipment
directly connected to the network.
(DTE) and Data Circuit-Terminating Equipment (DCE)
3.2.7 protocol, n—a standard method of communicating
for Synchronous Operation on Public Data Networks
over a network.
X.25 Interface Between Data Terminal Equipment (DTE)
and Data Circuit Terminating Equipment (DCE) for Ter-
3.2.8 repeater, n—a network device that repeats signals
minals Operating in the Packet Mode and Connected
from one cable onto one or more other cables, while restoring
Public Data Networks by Dedicated Circuit
signal timing and waveforms.
2.7 EIA/TIA Standard:
3.2.9 router, n—a device capable of filtering/forwarding
232C
packets based upon data link layer information.
568 Commercial Building Telecommunications Wiring
Standard (ANSI/EIA/TIA-568-91)
3.2.10 server, n—a device that stores data for network users
and provides network access to that data.
2.8 Internet Request for Comments (RFCs) Standards:
RFC 768 User Datagram Protocol (UDP)
3.2.11 topology, n—the arrangement of the nodes and con-
RFC 791 Internet Protocol (IP)
necting hardware that comprises the network.
RFC 792 Internet Control Message Protocol (CMP)
3.2.12 WAN (wide area network), n—a network using com-
RFC 793 Transmission Control Protocol (TCP)
mon carrier transmission services for transmission of data over
RFC 821 Simple Mail Transfer Protocol (SMTP)
a large geographical area.
RFC 826
RFC 854 TELNET Protocol
4. Significance and Use
RFC 894
RFC 903
4.1 This guide is intended to provide an understanding of
RFC 959 File Transfer Protocol (FTP)
the wide range of communication protocols standards, allow-
ingtheusertounderstandbettertheirapplicabilitytoshipboard
6 networks and marine platform computerized systems. For
Available from Electronic Industries Alliance (EIA), 2500 Wilson Blvd.,
computerized networks and systems, communication protocols
Arlington, VA 22201, http://www.eia.org.
Available from the U.S. Department of Commerce, National Technical Infor-
are necessary for integrating various system devices, providing
mation Service (NTIS), 5285 Port Royal Rd., Springfield, VA 22161, http://
functionality between dissimilar subnetworks, or for enabling
www.ntis.gov.
remote connections, either pier side or through geophysical
Documents may be obtained by means of anonymous ftp from the
hosts:ds.internic.net, directory rfc. communication technologies.
F1757 − 96 (2015)
4.2 The wide variety and scope of digital communication
protocol standards adds greatly to the complex decision pro-
cess for specifying compatible protocols for system applica-
tions and related devices for the myriad of potential shipboard
systems.However,theusermustidentifytheinitialnetworking
requirements, so once the network protocols under evaluation
are well understood, the decision process should determine the
appropriate network protocols. Therefore, this guide is in-
tended to reduce the complexity involved with protocol selec-
tion and implementation.
4.3 Network protocols define an agreed, quantifiable entity,
or set of rules, by which user computers, system networks, and
internetworking devices communicate and exchange informa-
tion. Communication protocols specify essential networking
guidelines, such as physical interface connections, or data
format and control operations between two communicating
computers. Ship and marine digital communication protocol
FIG. 1 Local Network Topologies
requirements are no different than their land-based networked
counterparts. Both require standardized protocol selection, in
various protocol categories, including LAN standards, WAN
central element uses circuit switching to establish a dedicated
protocols, LAN/WAN protocols, network management, wiring
pathbetweentwostationswishingtocommunicate(seeFig.1).
hub configurations/operations, hardware platforms, operating
6.2.2 RingTopology—Theringtopologyconsistsofaclosed
systems, and network applications.
loop, with each node attached to a repeating element. Data
circulate around the ring on a series of point-to-point data links
5. Origin of Protocol Development
between repeaters. A station wishing to transmit waits for its
5.1 Communication protocol standards have been devel-
next turn and then sends data out onto the ring in the form of
oped or refined through three separate processes, identified as
a packet (see Fig. 1).
follows:
6.2.3 Bus/Tree Topology—The bus or tree topology is char-
5.1.1 Defacto Protocol Standards—Acquired widespread
acterized by the use of a multipoint medium.The bus is simply
use of a popular technique adopted by vendors and developers;
a special case of the tree, in which there is only one trunk, with
5.1.2 Dejur Protocol Standards—Standards making bodies;
no branches. Because all devices share a common communi-
and,
cations medium, only one pair of devices on a bus or tree can
5.1.3 Proprietary Protocol Standard—Private corporation-
communicate at a time. A distributed medium access protocol
based protocols with limited interoperability.
is used to determine which station may transmit (see Fig. 1).
5.2 The open standards approach is now the norm, which
6.3 Internetwork Topology—The common topologies used
allows multiple protocol networking solutions to be available,
to support emerging networking topologies requiring the inte-
and as a result, proprietary protocols are now becoming
gration of data, video and voice, as well as higher transport
obsolete.
bandwidth are backbone, hierarchical, and mesh (see Fig. 2).
6.3.1 Backbone—Backbone configurations are used in net-
6. Local Network Interconnection
working environments in which local networks are connected
6.1 The characteristic of a local network is determined
over high-speed backbone cables. Bridges and routers are used
primarily by three factors: transmission medium, topology, and
to manage the data passing between interconnected networks
medium access control protocol.
and the backbone (see Fig. 2).
6.1.1 The principal technological elements that determine
6.3.2 Hierarchial—In the hierarchial configuration, star-
the nature of a local network are the topology and transmission
configuredhubsarewiredtoacentralhubthathandlesinterhub
mediumofthenetwork.Together,itdeterminesthetypeofdata
traffic. Routers and Asynchronous Transfer Mode (ATM)
that may be transmitted, the speed and efficiency of
technology provide support to traffic intensive network appli-
communications, and the type of applications that a network
cations requiring the integration of voice, video, and data (see
may support.
Fig. 2).
6.1.2 Interconnectingasetoflocalnetworksisreferredtoas
6.3.3 Mesh—In mesh configurations, there are at least two
an internetworking. The local networks are interconnected by
pathways to each node. This is a common configuration in
devices generically called gateways. Gateways provide a
emerging high-speed enterprise networks requiring the integra-
communication path so that data can be exchanged between
tion of voice, video, and data. It is composed of internetwork-
networks.
ingdevices,suchasbridges,routers,andATMtechnology.The
6.2 Topology—The common topologies used for local net- internetworking devices provide efficient paths for data to
works are star, ring, and bus/tree (see Fig. 1). travel from one point to another in this configuration. Mesh
6.2.1 Star Topology—In a star topology, a central switching networks often are used because of reliability; when one path
element is used to connect all the nodes in the network. The goes down, another can take over (see Fig. 2).
F1757 − 96 (2015)
FIG. 2 Internetwork Topology
TABLE 1 Optical Fiber Cabling
Type Light Source Bandwidth Primary Application
Single mode laser 100 GHz telephone traffic
6.4 Cabling—Cabling falls into the following categories:
Multimode
...
This document is not an ASTM standard and is intended only to provide the user of an ASTM standard an indication of what changes have been made to the previous version. Because
it may not be technically possible to adequately depict all changes accurately, ASTM recommends that users consult prior editions as appropriate. In all cases only the current version
of the standard as published by ASTM is to be considered the official document.
Designation: F1757 − 96 (Reapproved 2008) F1757 − 96 (Reapproved 2015)An American National Standard
Standard Guide for
Digital Communication Protocols for Computerized
Systems
This standard is issued under the fixed designation F1757; the number immediately following the designation indicates the year of
original adoption or, in the case of revision, the year of last revision. A number in parentheses indicates the year of last reapproval. A
superscript epsilon (´) indicates an editorial change since the last revision or reapproval.
1. Scope
1.1 The principal content of this guide provides a road map to implement a communication network applicable to ship and
marine computer systems by:
1.1.1 Examining the relationship of digital communication protocols as a network technological infrastructure,
1.1.2 Outlining the basic building blocks of network topologies and transmission techniques associated with the implementation
of transmission media in a network environment; and,
1.1.3 Identifying operating system and environments.
1.2 Using the Open System Interconnection (OSI) model, which provides a layered approach to network functionality and
evaluation, common network communications protocols are identified and characterized in this guide according to lower and upper
layer protocols corresponding to their degree and type of functionality.
1.3 Although it is desirable that network users, designers, and administrators recognize and understand every possible
networking protocol, it is not possible to know the intimate details of every protocol specification. Accordingly, this guide is not
intended to address fully every hardware and software protocol ever developed for commercial use, which spans a period of about
25 years. Instead, the user of this guide will be introduced to a brief overview of the majority of past and present protocols which
may comprise a ship or marine internetwork, to include Local Area Networks (LANs), Wide Area Networks (WANs), and related
hardware and software that provide such network interoperability and data transfer.
1.4 While this guide provides an understanding of the wide range of communication protocols, the user is recommended to
consult the reference material for acquiring a more comprehensive understanding of individual communication protocols.
However, by examining the basic functions of protocols and reviewing the protocol characterization criteria identified in this guide,
the user will be more apt to understanding other protocols not mentioned or addressed herein.
2. Referenced Documents
2.1 ASTM Standards:
E1013 Terminology Relating to Computerized Systems (Withdrawn 2000)
2.2 ANSI Standards:
X3T9.5 High Speed Local Network
X3.139 Fiber Distributed Data Interface (FDDI) – Token Ring Media Access Control (MAC)
X3.148 Fiber Distributed Data Interface (FDDI)– Token Ring Physical Layer Protocol (PHY)
X3.166 Fiber Distributed Data Interface (FDDI) – Token Ring Physical Layer Medium Dependent (PMD)
X3.172 American National Standard Dictionary for Information Systems
2.3 IEEE Standards:
100 Standard Dictionary for Electrical and Electronic Terms
610 Standard Glossary for Software Engineering Terminology
610.7 Standard Glossary of Computer Networking Terminology
This guide is under the jurisdiction of ASTM Committee F25 on Ships and Marine Technology and is the direct responsibility of Subcommittee F25.05 on Computer
Applications.
Current edition approved May 1, 2008May 1, 2015. Published July 2008June 2015. Originally approved in 1996. Last previous edition approved in 20022008 as
F1757 - 96F1757 – 96 (2008).(2002). DOI: 10.1520/F1757-96R08.10.1520/F1757-96R15.
For referenced ASTM standards, visit the ASTM website, www.astm.org, or contact ASTM Customer Service at service@astm.org. For Annual Book of ASTM Standards
volume information, refer to the standard’s Document Summary page on the ASTM website.
The last approved version of this historical standard is referenced on www.astm.org.
Available from American National Standards Institute (ANSI), 25 W. 43rd St., 4th Floor, New York, NY 10036, http://www.ansi.org.
Available from Institute of Electrical and Electronics Engineers, Inc. (IEEE), 445 Hoes Ln., P.O. Box 1331, Piscataway, NJ 08854-1331, http://www.ieee.org.
Copyright © ASTM International, 100 Barr Harbor Drive, PO Box C700, West Conshohocken, PA 19428-2959. United States
F1757 − 96 (2015)
802.1 High Level Interface (Internetworking)
802.2 Logical Link Control
802.3 CSMA/CD Medium Access Control
802.4 Token Bus Medium Access Control
802.5 Token Ring Medium Access Control
802.6 Metropolitan Area Networking
802.8 Fiber Optic Technical Advisory Group
802.9 Local and Metropolitan Area Networks: Integrated Services (IS) LAN Interface at the Medium Access Control (MAC) and
Physical (PHY) Layers
803.5
2.4 ISO Standards:
7498 Information Processing Systems–Open Systems Interconnection–Basic Reference Model
9040/9041 Virtual Terminal (VT)
8831/8832 Job Transfer and Manipulation (JTM)
8571/8572 File Transfer Access Management (FTAM)
9595/9596 Common Management Information Service/Protocol (CMIP)
8823 Connection Oriented Presentation Protocol
8327 Connection Oriented Session Protocol
8073 Connection Oriented Transport Protocol
8473 Connectionless Network Service
8208 Packet Level Protocol
8802-2 Logical Link Control
9314-2 FDDI
8802-3 CSMA/CD (Bus)
8802-4 Token Bus
8802-5 Token Ring
7776 Link Access Protocol/Link Access Protocol-Balanced (LAP/LAPB)
7809 High-Level Data Link Control (HDLC)
2.5 ITU Standards:
X.25 Packet Level Protocol
X.226 Connection Oriented Presentation Protocol
X.225 Connection Oriented Session Protocol
X.224 Connection Oriented Transport Protocol
2.6 CCITT Standards:
V.35
X.21 (BIS) Interface Between Data Terminal Equipment (DTE) and Data Circuit-Terminating Equipment (DCE) for
Synchronous Operation on Public Data Networks
X.25 Interface Between Data Terminal Equipment (DTE) and Data Circuit Terminating Equipment (DCE) for Terminals
Operating in the Packet Mode and Connected Public Data Networks by Dedicated Circuit
2.7 EIA/TIA Standard:
232C
568 Commercial Building Telecommunications Wiring Standard (ANSI/EIA/TIA-568-91)
2.8 Internet Request for Comments (RFCs) Standards:
RFC 768 User Datagram Protocol (UDP)
RFC 791 Internet Protocol (IP)
RFC 792 Internet Control Message Protocol (CMP)
RFC 793 Transmission Control Protocol (TCP) (TCP)
RFC 821 Simple Mail Transfer Protocol (SMTP)
RFC 826
RFC 854 TELNET Protocol
RFC 894
RFC 903
RFC 959 File Transfer Protocol (FTP)
RFC 1042
Available from Electronic Industries Alliance (EIA), 2500 Wilson Blvd., Arlington, VA 22201, http://www.eia.org.
Available from the U.S. Department of Commerce, National Technical Information Service (NTIS), 5285 Port Royal Rd., Springfield, VA 22161, http://www.ntis.gov.
Documents may be obtained via by means of anonymous ftp from the hosts:ds.internic.net, directory rfc.
F1757 − 96 (2015)
RFC 1157 Simple Network Management Protocol
RFC 1201
3. Terminology
3.1 Definitions:
3.1.1 The terminology used in this guide is defined in Terminology E1013, IEEE 610, and ANSI X3.172, with the following
additions defined in 3.2.
3.2 Definitions of Terms Specific to This Standard:
3.2.1 bridge, n—a device that interconnects local or remote networks no matter what network protocol that is, TCP/IP or IPX,
are involved. Bridges form a single logical network.
3.2.2 hub, n—a central location for the attachment of cables from nodes and other network components.
3.2.3 internetwork, n—a collection of LANs using different network operating systems that are connected to form a larger
network.
3.2.4 LAN (local area network), n—a data communication system consisting of a collection of interconnected computers,
sharing applications, data and peripherals.
3.2.5 network operating system (NOS), n—the software for a network that runs in a file server and control access to files and
other resources from multiple users.
3.2.6 node(s), n—any intelligent device connected to the network. This includes terminal servers, host computers, and any other
devices, such as printers and terminals, that are directly connected to the network.
3.2.7 protocol, n—a standard method of communicating over a network.
3.2.8 repeater, n—a network device that repeats signals from one cable onto one or more other cables, while restoring signal
timing and waveforms.
3.2.9 router, n—a device capable of filtering/forwarding packets based upon data link layer information.
3.2.10 server, n—a device that stores data for network users and provides network access to that data.
3.2.11 topology, n—the arrangement of the nodes and connecting hardware that comprises the network.
3.2.12 WAN (wide area network), n—a network using common carrier transmission services for transmission of data over a large
geographical area.
4. Significance and Use
4.1 This guide is intended to provide an understanding of the wide range of communication protocols standards, allowing the
user to understand better their applicability to shipboard networks and marine platform computerized systems. For computerized
networks and systems, communication protocols are necessary for integrating various system devices, providing functionality
between dissimilar subnetworks, or for enabling remote connections, either pier side or through geophysical communication
technologies.
4.2 The wide variety and scope of digital communication protocol standards adds greatly to the complex decision process for
specifying compatible protocols for system applications and related devices for the myriad of potential shipboard systems.
However, the user must identify the initial networking requirements, so once the network protocols under evaluation are well
understood, the decision process should determine the appropriate network protocols. Therefore, this guide is intended to reduce
the complexity involved with protocol selection and implementation.
4.3 Network protocols define an agreed, quantifiable entity, or set of rules, by which user computers, system networks, and
internetworking devices communicate and exchange information. Communication protocols specify essential networking
guidelines, such as physical interface connections, or data format and control operations between two communicating computers.
Ship and marine digital communication protocol requirements are no different than their land-based networked counterparts. Both
require standardized protocol selection, in various protocol categories, including LAN standards, WAN protocols, LAN/WAN
protocols, network management, wiring hub configurations/operations, hardware platforms, operating systems, and network
applications.
5. Origin of Protocol Development
5.1 Communication protocol standards have been developed or refined through three separate processes, identified as follows:
5.1.1 Defacto Protocol Standards —Standards—Acquired widespread use of a popular technique adopted by vendors and
developers;
5.1.2 Dejur Protocol Standards—Standards making bodies; and,
5.1.3 Proprietary Protocol Standard—Private corporation-based protocols with limited interoperability.
5.2 The open standards approach is now the norm, which allows multiple protocol networking solutions to be available, and as
a result, proprietary protocols are now becoming obsolete.
F1757 − 96 (2015)
6. Local Network Interconnection
6.1 The characteristic of a local network is determined primarily by three factors: transmission medium, topology, and medium
access control protocol.
6.1.1 The principal technological elements that determine the nature of a local network are the topology and transmission
medium of the network. Together, it determines the type of data that may be transmitted, the speed and efficiency of
communications, and the type of applications that a network may support.
6.1.2 Interconnecting a set of local networks is referred to as an internetworking. The local networks are interconnected by
devices generically called gateways. Gateways provide a communication path so that data can be exchanged between networks.
6.2 Topology—The common topologies used for local networks are star, ring, and bus/tree (see Fig. 1).
6.2.1 Star Topology—In a star topology, a central switching element is used to connect all the nodes in the network. The central
element uses circuit switching to establish a dedicated path between two stations wishing to communicate (see Fig. 1).
6.2.2 Ring Topology—The ring topology consists of a closed loop, with each node attached to a repeating element. Data circulate
around the ring on a series of point-to-point data links between repeaters. A station wishing to transmit waits for its next turn and
then sends data out onto the ring in the form of a packet (see Fig. 1).
6.2.3 Bus/Tree Topology—The bus or tree topology is characterized by the use of a multipoint medium. The bus is simply a
special case of the tree, in which there is only one trunk, with no branches. Because all devices share a common communications
medium, only one pair of devices on a bus or tree can communicate at a time. A distributed medium access protocol is used to
determine which station may transmit (see Fig. 1).
6.3 Internetwork Topology—The common topologies used to support emerging networking topologies requiring the integration
of data, video and voice, as well as higher transport bandwidth are backbone, hierarchical, and mesh (see Fig. 2).
6.3.1 Backbone—Backbone configurations are used in networking environments in which local networks are connected over
high-speed backbone cables. Bridges and routers are used to manage the data passing between interconnected networks and the
backbone (see Fig. 2).
6.3.2 Hierarchial—In the hierarchial configuration, star-configured hubs are wired to a central hub that handles interhub traffic.
Routers and Asynchronous Transfer Mode (ATM) technology provide support to traffic intensive network applications requiring
the integration of voice, video, and data (see Fig. 2).
6.3.3 Mesh—In mesh configurations, there are at least two pathways to each node. This is a common configuration in emerging
high-speed enterprise networks requiring the integration of voice, video, and data. It is composed of internetworking devices, such
as bridges, routers, and ATM technology. The internetworking devices provide efficient paths for data to trav
...










Questions, Comments and Discussion
Ask us and Technical Secretary will try to provide an answer. You can facilitate discussion about the standard in here.